How to permanently set workspace switching keys on icewm?

If I set the keys to switch workspaces in icewm through it’s menu, it resets the next time i restart icewm, is there a way to set it permanently?

@rabcor
Initially, if you want to use customize by user
cp -r /usr/share/icewm/ ~/.config/
Having done
Settings/Preferences/KeySysWorkspace KeySysWorkspace1 Super+1
OK
Settings/Preferences/Save Modifications # this modifies the

preferences file in ~/.config/icewm containing

#  Goes to workspace 1.
KeySysWorkspace1="Super+1"

Rebooted and checked (with Super+1 /2). It seems to work.

Edit1:
I switched to icewm-session as it supports startup either in ~/.icewm or ~/.config/icewm
and now config files are in
~/.config/icewm

Based on https://wiki.archlinux.org/title/IceWM

1 Like

thanks. You can also in the menu where you can configure the keys hit the save modifications button to make the changes permanent, I think the way you described is bettter though.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.