How to modify python version for packge build via yay?

I am trying to install veusz, a scientific plotting packge, but my problem is that it seems to run another version of python than on my EOS system (i.e. I cannot import data).

I solved this previously in manjaro via pamac, following this solution:

Could someone help me building this package, i.e. I just need to run:

yay veusz-git

but don’t now how or where I can the following option for my python version:

ln -s /usr/lib/python3.9/site-packages/PyQt5/bindings/ NEW/PyQt5

What makes you think it is python version problem?

That Manjaro issue was caused because python 3.9 hadn’t made it to stable at the time.

However, EOS doesn’t work like that so it should already have Python 3.9.

EDIT: To answer your question, you use yay --editmenu -S veusz-git but I don’t think that should be needed in this case.

1 Like

Ok, let me try. I think it’s the python version based on the error I got when trying to load my data, which was referring to my python 3.9 location.

I get the following when trying to build (I am on i3wm):

PKGBUILDs to edit?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> a

 -> $EDITOR is not set
 -> Add $EDITOR or $VISUAL to your environment variables
==> Edit PKGBUILD with?

Any idea how I can set my editor, so I can check the code and perhaps edit the python version if needed? Thanks so much for your help!

Edit: found it, it’s pretty easy:

export EDITOR=nano
1 Like

You can put that line in your .bashrc so it is always set.

1 Like

Thanks, I tried but it did not pick it up. I did then

source .bashrc

Perhaps adding it at the end of the .bashrc file is not the right place. Anyhow that is my lack of knowledge, need to dig a bit more into bash…

I did not yet find a solution, the error message I get in the program (it starts) when I try to import data is a long list, this is the beginning if that helps:

`Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/veusz/dialogs/", line 274, in slotImport
  File "/usr/lib/python3.9/site-packages/veusz/dataimport/", line 202, in doImport
  File "/usr/lib/python3.9/site-packages/veusz/document/", line 184, in applyOperation
    retn =
  File "/usr/lib/python3.9/site-packages/veusz/dataimport/", line 274, in do
    retn = self.doImport()
  File "/usr/lib/python3.9/site-packages/veusz/dataimport/", line 85, in doImport
    csvr.setData(self.outdatasets, linkedfile=LF)
  File "/usr/lib/python3.9/site-packages/veusz/dataimport/", line 405, in setData
    ds = datasets.Dataset(
  File "/usr/lib/python3.9/site-packages/veusz/datasets/", line 188, in __init__ = convertNumpy(data)
  File "/usr/lib/python3.9/site-packages/veusz/datasets/", line 42, in convertNumpy
    a = N.array(a, dtype=N.float64)
ValueError: could not convert string to float: 'd.l.'`

That is why I thought it may point to the wrong python folder or something similar.

Edit: I think I could also try to install the veusz instead of veusz git package but doubt it will fix it.

I would try that first. Maybe the *-git package is broken right now.

same thing. When running the program via terminal it says the following:

VO table import: astropy module not available
SAMP: sampy module not available

never heard of these packages before.

Ok, now I feel stupid. Just found the solution, was not a problem with the program but with my data format!

Thought it was the same problem I had on manjaro a couple of months ago.

Thanks, through all this I at least learned something:

yay --editmenu -S veusz-git 

To edit package build on yay. Thank you!

Not sure if it may be worth deleting the thread, don’t want to confuse veusz users…

1 Like