How to make timeshift snapshot appear in grub?

I am using timeshift with btrfs and having a snapshot, but It’s not appearing on the grub.

I have installed timeshift-autosnap.

System Info:

System:
  Kernel: 5.4.153-1-lts54 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts54 
  root=UUID=140ff4ed-d56a-4a46-8c79-545720e64c75 rw rootflags=subvol=@ quiet 
  loglevel=3 nowatchdog 
  Desktop: Cinnamon 5.0.5 tk: GTK 3.24.30 vt: 7 dm: LightDM 1.30.0 
  Distro: EndeavourOS base: Arch Linux 
Machine:
  Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A 
  serial: <filter> Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.15.0 
  date: 06/16/2021 
CPU:
  Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP 
  arch: Amber/Kaby Lake note: check family: 6 model-id: 8E (142) stepping: 9 
  microcode: EA cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 21599 
  Speed: 2500 MHz min/max: 400/2500 MHz Core speeds (MHz): 1: 2500 2: 2500 
  3: 2502 4: 2500 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300 
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / 
  Radeon 520 Mobile] 
  vendor: Dell driver: radeon v: kernel alternate: amdgpu bus-ID: 01:00.0 
  chip-ID: 1002:6660 class-ID: 0380 
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 1-5:3 chip-ID: 0bda:5769 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.org 1.20.13 driver: loaded: ati,intel,radeon 
  unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.4.153-1-lts54 running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.38 running: no 
Network:
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 
  bus-ID: 02:00.0 chip-ID: 8086:3165 class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: N/A modules: r8169 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8136 
  class-ID: 0200 
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  v: 0.8 bus-ID: 1-8:5 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: not found 
  rfk-block: hardware: no software: no address: see --recommends 
Drives:
  Local Storage: total: 931.51 GiB used: 197.11 GiB (21.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: SDM3 scheme: GPT 
Partition:
  ID-1: / raw-size: 100.1 GiB size: 100.1 GiB (100.00%) 
  used: 9.29 GiB (9.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1 
  ID-2: /boot/efi raw-size: 250.2 MiB size: 246.3 MiB (98.45%) 
  used: 562 KiB (0.2%) fs: vfat dev: /dev/sda3 maj-min: 8:3 
  ID-3: /home raw-size: 831.17 GiB size: 831.17 GiB (100.00%) 
  used: 187.82 GiB (22.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-4: /var/log raw-size: 100.1 GiB size: 100.1 GiB (100.00%) 
  used: 9.29 GiB (9.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1 
Swap:
  Alert: No swap data was found. 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: 49.0 C gpu: radeon temp: 45.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 223 Uptime: 5m wakeups: 1 Memory: 7.65 GiB 
  used: 1.49 GiB (19.4%) Init: systemd v: 249 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: pacman: 909 lib: 246 Shell: Bash v: 5.1.8 
  running-in: gnome-terminal inxi: 3.3.06 

You need to install grub-btrfs for that.

I just installed grub-btrfs and restarted but snapshots option didn’t appear on grub.

You probably need to run sudo grub-mkconfig -o /boot/grub/grub.cfg to get it started.

Check out the GitHub site for setup details: https://github.com/Antynea/grub-btrfs