How to make bluetooth applet work?

I added bluetooth-applet & to ~/.config/qtile/ but I don’t see the Bluetooth applet anywhere.

When I run bluetoothctl I get the following message: “Waiting to connect to bluetoothd…”.

I have to run sudo /usr/lib/bluetooth/bluetoothd -n -d to enter bluetoothctl. Then bluetooth works fine.

However, I would prefer to interract with bluetooth through GUI (applet).

a look at the EndeavourOS-Wiki provides the explanation.

sudo systemctl start bluetooth
sudo systemctl enable bluetooth

I hope this helps.

1 Like


With sudo systemctl start bluetooth, now bluetoothctl works fine, but still no applet…

Have a look at the following thread where the OP seems to have solved a similar problem as yours:

Well, it is because I read this topic that I added bluetooth-applet &, but in my case it didn’t work…

Now , I don’t know if this will make any difference, but from that thread:

blueman-applet & disown
1 Like

It seems that the author of the thread made a typo, because he first mentioned bluetooth-applet. My system can’t find blueman-applet, how can I install it?

You might be right. That could be a typo.

But more specifacally the disown part that seems to be lacking in your line.

you have blueman install? i no use eos qtile or qtile . just thought

1 Like

I don’t have blueman, shall I do sudo pacman -S blueman? Is it compatible with Qtile?

one way find out … :blush: i no see problem use bluetoothctl :innocent:


Blueman should be DE/WM agnostic if I am not mistaken.


Everything works fine now, thank you all.
To sum up, here is what has to be done to make Bluetooth applet work:

  1. $ sudo pacman -S blueman
  2. add the following line to ~/.config/qtile/ blueman-applet &
  3. $ sudo systemctl enable bluetooth
  4. $ reboot
1 Like

see. just need install + small read .

glad you fix your problem :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.