How to install AMD HD 4350 driver?

I have AMD HD 4350 (Rv 710) GPU on my EndeavourOS system. How can I install drivers?

you don’t. On Linux, AMD and Intel drivers are installed by default because they are part of the kernel and mesa.

The only thing that might be necessary is switching to mesa-amber in case your card is too old to still be supported by mesa.

https://archlinux.org/packages/extra/x86_64/mesa-amber/

1 Like

Do I need to install mesa-amber?

You may need the following kernel parameters either with grub or also systemd-boot.

radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1

How can I do that? I new on Linux sorry.

Depends on whether you are using grub or systemdboot.

Edit: Do you already have EOS installed?

I think you’ll find that the HD4350 will work when you install EOS. You may just need the kernel parameters or you may not. I had my HD 3870 running on EOS without issue.

yes endeavourOS is installed on my system

I’m using grub for bootloader.

Sorry for late reply btw.

Do you find any issue with the graphics then? What does it show for

inxi -Ga

Edit: I don’t think you need the kernel parameters anyway because they are for the Southern Islands and Sea Islands series cards which yours is before that.

Screen tearing happens in Firefox.

It show:

Graphics:
  Device-1: AMD RV710 [Radeon HD 4350/4550] vendor: ASUSTeK driver: radeon
    v: kernel alternate: amdgpu arch: TeraScale code: R6xx/RV6xx/RV7xx
    process: TSMC 55-65nm built: 2005-13 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 ports: active: VGA-1 empty: DVI-I-1,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 1002:954f class-ID: 0300 temp: 39.0 C
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: radeon unloaded: modesetting alternate: fbdev,vesa dri: r600
    gpu: radeon display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.00x9.37")
    s-diag: 449mm (17.69")
  Monitor-1: VGA-1 mapped: VGA-0 model: Acer V193W serial: LC1080344213
    built: 2009 res: 1440x900 dpi: 90 gamma: 1.07 size: 408x255mm (16.06x10.04")
    diag: 472mm (18.6") ratio: 16:10 modes: max: 1440x900 min: 720x400
  API: OpenGL v: 3.3 Mesa 23.1.3 renderer: AMD RV710 (DRM 2.50.0 /
    6.4.3-arch1-1 LLVM 15.0.7) compat-v: 3.0 direct-render: Yes

for

inxi -Ga

it is already using the correct driver.

screen tearing in Firefox can be solved by configuration, I currently don’t have the time to help with hat but others should be able to help.

1 Like

Thank you.

Have you tried change this setting in Firefox? See if it makes any difference.

Try disabling smooth scrolling in Settings > General >Browsing.

Other option is to try creating the following file in

/etc/X11/xorg.conf.d/20-amdgpu.conf

add

 Section "Device"
         Identifier "AMD" 
         Driver "radeon"
         Option "Tear Free" "true"
EndSection

Hopefully i got this right. I am not an expert at following the Arch wiki. :sunglasses:

1 Like

I’m already disable smooth scrolling in Firefox.

Thank you so much.

So did that work?

1 Like