How to fix systemd-backlight failed to reload on dell?

[tushar@tushar-inspiron3558 ~]$ systemctl --failed
  UNIT                                               LOAD   ACTIVE SUB    DESCRIPTION                                                      
● systemd-backlight@leds:dell::kbd_backlight.service loaded failed failed Load/Save Screen Backlight Brightness of leds:dell::kbd_backlight

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.
[tushar@tushar-inspiron3558 ~]$ 

That appears to be the keyboard LED backlight, and you can get more information by looking at the journal:

journalctl -eu systemd-backlight@leds:dell::kbd_backlight.service

You might also check the Arch wiki for similar laptop models.

I don’t have any LED backlight in keyboard. Should I disable it?

If the failing service is trying to do something that’s not supported by your hardware, then disabling the service would make sense, yes.

Just mask the service then it won’t load. If you decide later you want it you can unmask it.

Why mask rather than disable?

Sometimes disable hasn’t worked for me but mask did. I don’t know why? I’ve just experienced that before and masking it stops it from loading. If disable works then there is no problem.

mask will prevent the service from being loaded no matter what (it’s effectively the same as deleting the unit file from disk, systemctl simply won’t load it), disable means it won’t start automatically unless triggered by something else (e.g. if another service depends on it then it can still be loaded).

1 Like

The OP said he doesn’t have any LED backlight in keyboard so if another service keeps trying to load it and disable doesn’t work then masking is an option. That was my thinking on that. :man_shrugging:


Yeah same here. The service was still running after disabling it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.