How to down clock a GPU

Hi there,

So I have Lutris 5.4-2; Wine staging 5.3-1. I am playing Guild Wars 2; most of the time plays fine, but it gets hot.

It is a Dell inspiron 15 (details below), it has a Radeon card, but the body is just a regular laptop, not a lot of cooling. So I want to know if there is a way to down clock it a notch (or maybe two) to try to keep it from going too hot.

I have EOS on an M.2; and the game is installed on a mechanical 2TB. I also notice that the inxi -F command shows me graphics device 1 as Intel, but I don’t see a device 2 radeon like when I previously had fedora on it.

So maybe I need to switch drivers / kernels, but I am not a tech person, I wanted to ask first before I did something silly. :joy:

I leave here what the inxi -F gave me back,

Thx.

System:    Host: dell Kernel: 5.5.7-arch1-1 x86_64 bits: 64 Desktop: Budgie 10.5.1 Distro: EndeavourOS 
Machine:   Type: Laptop System: Dell product: Inspiron 5570 v: N/A serial: <root required> 
           Mobo: Dell model: 09NFWR v: A00 serial: <root required> UEFI: Dell v: 1.2.3 date: 05/15/2019 
Battery:   ID-1: BAT0 charge: 41.3 Wh condition: 41.3/42.0 Wh (98%) 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP L2 cache: 6144 KiB 
           Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.7 driver: amdgpu,ati,intel unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.6 Mesa 19.3.4 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.5.7-arch1-1 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: 54:bf:64:07:2c:3e 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci 
           IF: wlan0 state: up mac: fc:01:7c:5a:9f:71 
           Device-3: Qualcomm Atheros type: USB driver: btusb 
Drives:    Local Storage: total: 2.29 TiB used: 204.60 GiB (8.7%) 
           ID-1: /dev/nvme0n1 vendor: A-Data model: SX6000PNP size: 476.94 GiB 
           ID-2: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB 
Partition: ID-1: / size: 202.49 GiB used: 18.11 GiB (8.9%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-2: swap-1 size: 31.25 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p4 
Sensors:   System Temperatures: cpu: 46.0 C mobo: 40.0 C sodimm: 41.0 C gpu: amdgpu temp: 44 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 251 Uptime: 52m Memory: 7.68 G

Hello @Daemonicvs
Honestly looking at the output of Inxi -F your temps don’t look high to me. Is it possible to go to root and give the output of inxi -G

1 Like

Do you only think it gets hot because of the shown values or does it really feel hot when you touch it? If the second was the case you would have to look, if sensorsd is configured correctly.
Did you ever run sensors-detect as root? That one detects all available sensors and, at the end, writes a config file.

Have you seen this article from Phoronix?

https://www.phoronix.com/scan.php?page=news_item&px=MTQ3MDE

Edit: It is a little bit dated but just wondered if this is an issue anymore?

1 Like

No I didn’t know that one. Thanks for linking. I just gave the advice because I’ve been using sensors-detect for a long time now without any issues. But as far as I understand the article they excluded the problematic tests in recent versions. Maybe some research will show, if there is still a risk using it.

Thx Ricklinux, I read it now;

I don’t think I have any wrong with my hardware, neither I ran diagnostics, the games works fine, no errors, no flikering, is all fine,

I just mean like Trekkie said, it feels hot, like I can make tortillas on it , :rofl:

This is not a gaming laptop like the G3 or Legion, the case is a regular non-gaming case, slim metal, that happens to have a Radeon attached to it.

It was always hot, since out of the box, with W10, I just want to see if I could make it go slower / cooler in exchange of performance.

Not a gamer and i don’t use lm-sensors but i saw that. So you have no issue with using it?

Could you post inxi -G

No. Even on my Medion netbook (MD 61900), which is a lot newer than my desktop. The tests are not fully automated. You can decide for every sensor if you want to test for it or not. So if there are some risky chipsets/tests you can always skip them.

I would suggest trying some solutions here to see if they can help.

https://wiki.archlinux.org/index.php/CPU_frequency_scaling

ok, sudo inxi -G gives this

Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: server: X.Org 1.20.7 driver: amdgpu,ati,intel unloaded: fbdev,modesetting,vesa tty: N/A 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.6 Mesa 19.3.4

And thx for the wiki arc link, I’m reading now.

I ran lutris without the “use dedicated gpu”, and it was better, only intel gpu,
but I got 10 to 15 FPS lol.

I’m trying to figure out what AMD graphics it has as i see Intel UHD 620 running on modesetting.

Edit: Looks like it is AMD Radeon 530?

hwinfo --gfxcard executed as root would help. hwinfo most likely will have to be installed first.

1 Like

Sorry, I am not a very advanced user yet, how do I execute as root?
normal hwinfo --gfxcard gives this
it is late now, I check tomorrow, thx.

16: PCI 100.0: 0380 Display controller                          
  [Created at pci.386]
  Unique ID: VCu0.RKV9iouUFnA
  Parent ID: z8Q3.gj6kR2iKi71
  SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "ATI Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x6900 "Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0810 
  Revision: 0xc1
  Driver: "amdgpu"
  Driver Modules: "amdgpu"
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  Memory Range: 0xd0000000-0xd01fffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xefff (rw)
  Memory Range: 0xd0200000-0xd023ffff (rw,non-prefetchable)
  Memory Range: 0xd0240000-0xd025ffff (ro,non-prefetchable,disabled)
  IRQ: 141 (228144 events)
  Module Alias: "pci:v00001002d00006900sv00001028sd00000810bc03sc80i00"
  Driver Info #0:
    Driver Status: amdgpu is active
    Driver Activation Cmd: "modprobe amdgpu"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

24: PCI 02.0: 0300 VGA compatible controller (VGA)
  [Created at pci.386]
  Unique ID: _Znp.y7gAA8mCp10
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Device Name: "Onboard IGD"
  Model: "Intel UHD Graphics 620"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x5917 "UHD Graphics 620"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0810 
  Revision: 0x07
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xd1000000-0xd1ffffff (rw,non-prefetchable)
  Memory Range: 0xb0000000-0xbfffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf03f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 138 (337738 events)
  Module Alias: "pci:v00008086d00005917sv00001028sd00000810bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #24

That’s okay. Because I’m used to openSUSE, where it is necessary to run hwinfo either with absolute path or with root priviliges, I asked you to run as root. (it’s abviously different running EndeavourOS (Arch?))

So it looks like you have Hybrid Graphics Intel UHD 620 and AMD and both modules are loading. Are you able to disable the Intel Graphics in the Bios? Check this out first. Then here is some info to look at.

https://wiki.archlinux.org/index.php/PRIME

Ok, I was able to, well disable Intel turbo boost in the Bios, and it got better, but not disable intel graphics completely.

I will look into your prime link,

Thx.

Disabling the Turbo boost will help but you also may suffer for your game frame rates. I am not a gamer but if you can have a look at that info maybe you can get the switchable graphics working for Radeon and or Gpu offloading that may be of an advantage?