How to disable grub screen

I installed EndeavourOS as the only operating system in a laptop. I installed both the linux and the linux-lts kernels.

Right now, grub is showing up during the startup, and it offers to choose the kernel to boot.

How do I set the linux-lts as the default kernel, so that grub does not show up during startup?

Also, after configuring grub not to show up, how to get to the grub screen in case I ever need to boot a different kernel?

You have to edit your /etc/default/grub file.

Change GRUB_TIMEOUT_STYLE to hidden

I’m not sure about this, but there may be keyboard shortcuts to do this. If i’m not mistaken, holding down the SHIFT key will bring up the grub menu?

Make sure these two lines are in your /etc/default/grub

GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=saved

This will make grub remember the last choice of kernel.

After making changes, make sure to run sudo grub-mkconfig -o /boot/grub/grub.cfg

EDIT:
After some research, I came across this script , which might be what you’re looking for.

Do I need to make the changes you suggested if I use the script?

Nope. If you plan to use the script, just follow the instruction given in the README.

Oh, wait. If you want grub to remember your last kernel choice, you still need to make sure that these two lines are available in your /etc/default/grub:

GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=saved

Just as a follow up.

GRUB has a new option that might fit your needs:

2 Likes