How to controll screen brightness?

I just installed EOS on my Lenovo Legion 5 and the screen brightness up and down buttons are not working. I’ve tried adding quiet splash video.use_native_backlight=1 to /etc/default/grub, but to no avail.
Does anyone know how to solve this problem?

Did you run update-grub afterwards?

Sure did.

Can you change backlight with another method?

I’ve tried xrandr --output DP-1-0 --brightness 0.2, but that also didn’t work.

Which Legion? Which desktop environment/WM?

Works fine here, KDE/Sway on a Legion 5 :

  Host: xircon-legion Kernel: 6.1.5-zen2-1-zen arch: x86_64 bits: 64
    compiler: gcc v: 12.2.0 Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8
    wm: kwin_wayland dm: 1: GDM note: stopped 2: SDDM Distro: EndeavourOS
    base: Arch Linux
  Type: Laptop System: LENOVO product: 82JY v: Legion 5 17ACH6H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 17ACH6H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN
    serial: <superuser required> UEFI: LENOVO v: GKCN58WW date: 09/15/2022

It’s a Legion 5 15ACH6H. But it also used to work for on Kubuntu, but I also remember that neither of those worked on there, was something else, I just can’t remember what eventually made it work, nor can I find the forum post with the answer.

Which DE?

1 Like

It’s EOS with i3 as a WM. Not really sure what DE means.

bindsym XF86MonBrightnessUp exec brightnessctl -c backlight set +5%
bindsym XF86MonBrightnessDown exec brightnessctl -c backlight set 5%-

Install brightnessctl and (from memory) add yourself to the video group and reboot.

(D)esktop (E)nvironment as I asked in my first post.

1 Like

Tried the brightnessctl -c backlight set 50%, but it sadly didn’t work.

Are you in the video group? (Your user)

Yes, I did add my user to the video group.

Weird, we have nearly identical setups (mine is 17" and RTX3070) and it all works here…

Pretty weird indeed.
Maybe different nvidia driver versions?

Shouldn’t have - this is an Arch based distro - do not update at your peril :smiley:
My grub:

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 nohpet quiet resume=UUID=9d4e515c-9542-43fb-8175-1b1f8f27b762 loglevel=3 nowatchdog nvme_load=YES"


1 extra/nvidia-dkms 525.78.01-1 (42.4 MiB 68.7 MiB) (Installed)
    NVIDIA drivers - module sources

What does:

inxi -G


  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia
    v: 525.78.01
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1920x1080~120Hz
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon Graphics (renoir LLVM
    14.0.6 DRM 3.49 6.1.5-zen2-1-zen)

So you are running on the integrated AMD gpu not the nvidia any way :smiley:

The way the legion works is different to most laptops, yes you have a switchable mode, but you can also select the nVidia card to run by itself from the bios.

Try some of the other apps like light:

community/light 1.2.2-3 

And you did reboot after adding yourself to the video group?

Did reboot, didn’t work. Will try light now.