How to connect to RDP?

I have been trying to connect my RDP from EndeavourOS .
But cant find any good way to do it

i have used Remmina , KRDC , XRDP etc…
but all failed to connect to my server …

can you guys help me getting into it ?

Welcome to EOS!


Remmina is my go-to in this area. You will need the remmina-plugin-rdesktop from AUR:

yay remmina-plugin-rdesktop

Then run remmina, and add the RDP server as per usual, save+connect.

Also of note: Anydesk is a great tool for cross-platform remote fix-ups that I am finding I need to help far-flung family members. This is also in the AUR.
Or try Supremo, which runs ok-ish on Wine.

You don’t need remmina-plugin-rdesktop from the AUR.
Just use freerdp from the official repos. In my experience it’s better nowadays. I think all features freerdp once lacked are available nowadays. Also the AUR package hasn’t seen an update since december 2019.

1 Like

Tried it

but for me it didnt worked :frowning:

is there any other better solution ?

is this CLI based ?

If all the things you mentioned in your first post aren’t working, then it’s not a problem of the app. Could be firewall settings, wrong config, etc.

1 Like

You need to install the freerdp package via

sudo pacman -Syu freerdp

Then, inside Remmina, you get the option to choose RDP as a protocol. Specify the server, username and password and everything should work. If it doesn’t you need to know why your network won’t let you connect to it.

Also maybe try the IP of the computer you want to connect to and not the device name. That may help.


This helped me !!!

Thank you for your time and support

Regards ~BRiAN

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.