How do I stop this icon from appearing in plank dock?

As you can see in the screenshot below. The icon the red arrow is pointing to does not appear when I reboot my system. It shows up suddenly after certain applications are opened and cannot be removed. I drag it out of the plank dock, and it still remains. It’s the only application/icon that is doing this.

When I hover my mouse cursor over it, it says ‘Plasma Desktop Workspace’

How can I force this to stop appearing? My OCD is driving me up the wall :grin:

right click icon and uncheck the ‘keep in dock’ box

edit: also play with the restrict and lock settings or some variation of that (plank --preferences)

1 Like

Surely I know that much :joy:. It doesn’t provide that option.

plasma stuff should not be in dock, methinks, unless you invited it somehow. the only consistency is it launches itself if certain apps are launched? weird.

edit: maybe it’s a run dep to one of the apps you launch?

Yes very weird. I notice when I take a screenshot, the screenshot app summons it. The issue is, it doesn’t go away after it appears. It remains until the next system reboot. I also try to right-click it and click close, but it doesn’t close it.


disable ‘show unpinned’?

That sounds like it would work, but I can’t seem to change any options in plank without errors. The first time I downloaded plank and set it up, I edited settings in the same window, and it worked fine, but suddenly I cannot. Here’s what I am presented with in terminal when trying to edit any planks settings:

[WARN 16:56:58.792450] [Environment:165] XDG_SESSION_CLASS not set in this environment!
[WARN 16:56:58.792465] [Environment:196] XDG_SESSION_TYPE not set in this environment!
[CRITICAL 16:56:58.806387] [DBusManager:192] Not able to register our interfaces
[WARN 16:56:58.845600] Unable to get org.ayatana.bamf matcher: Error spawning command line “dbus-launch --autolaunch=d231201fe59541ca93f01841e5d5b7a8 --binary-syntax --close-stderr”: Child process exited with code 1
[CRITICAL 16:56:58.847892] [GLib-GIO] g_dbus_proxy_set_default_timeout: assertion 'G_IS_DBUS_PROXY (proxy)' failed
[CRITICAL 16:56:58.847897] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 16:56:58.850059] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 16:56:58.850062] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 16:56:58.852224] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 16:56:58.852226] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 16:56:58.854399] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 16:56:58.854401] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 16:56:58.856546] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 16:56:58.856550] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 16:56:58.858763] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 16:56:58.858766] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 16:56:58.860936] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 16:56:58.863383] [GLib-GIO] g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
[WARN 16:56:58.863596] Failed to get running applications: 
[CRITICAL 16:56:58.864056] [GLib] g_error_free: assertion 'error != NULL' failed
[WARN 16:56:58.864071] [Matcher:124] plank_matcher_active_launchers: runtime check failed: (_tmp3_ != NULL)
[CRITICAL 16:56:58.866238] [GLib-GIO] g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
[WARN 16:56:58.866386] Failed to register favorites: 
[CRITICAL 16:56:58.866860] [GLib] g_error_free: assertion 'error != NULL' failed
[WARN 16:56:58.868206] [Unity:92] Error spawning command line “dbus-launch --autolaunch=d231201fe59541ca93f01841e5d5b7a8 --binary-syntax --close-stderr”: Child process exited with code 1
[WARN 16:56:58.869499] [Unity:92] Error spawning command line “dbus-launch --autolaunch=d231201fe59541ca93f01841e5d5b7a8 --binary-syntax --close-stderr”: Child process exited with code 1

(plank:4755): dconf-WARNING **: 16:57:05.436: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=d231201fe59541ca93f01841e5d5b7a8 --binary-syntax --close-stderr”: Child process exited with code 1
[CRITICAL 16:57:05.446641] [GLib-GIO] g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
[WARN 16:57:05.447144] Failed to get running applications: 
[CRITICAL 16:57:05.448147] [GLib] g_error_free: assertion 'error != NULL' failed
[WARN 16:57:05.448169] [Matcher:124] plank_matcher_active_launchers: runtime check failed: (_tmp3_ != NULL)

(plank:4755): dconf-WARNING **: 16:57:07.226: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=d231201fe59541ca93f01841e5d5b7a8 --binary-syntax --close-stderr”: Child process exited with code 1
[CRITICAL 16:57:07.233018] [GLib-GIO] g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
[WARN 16:57:07.233619] Failed to get running applications: 
[CRITICAL 16:57:07.234874] [GLib] g_error_free: assertion 'error != NULL' failed
[WARN 16:57:07.234933] [Matcher:124] plank_matcher_active_launchers: runtime check failed: (_tmp3_ != NULL)

dconf errors?
I mean, I’ve never seen completely clean terminal output for any functioning program…but dconf suggests a settings conflict somewhere to me.
I always went gtk/gnome underneath my DE’s so Plasma bit over my head.
Will defer to other opinions now.

1 Like

what editor are you using?

Editor? I’m not using any editor in this circumstance?

I run sudo plank --preferences and that presents me with the Plank setting window that drunkenvicar posted above. The settings window doesn’t apply any changes and each time I try to change a setting, the terminal window provides a response with one of those errors.

I got it working. I had to remove sudo from the command that launches plank settings. Some reason sudo causes it to break.

you should never sudo an application that is for the user. I missed the fact that you used sudo to run plank. sudo is reserved for applications that need root access to run like your package manager. Never use it for normal use packages this is very dangerous.

1 Like

That makes sense. I’ll make sure never to do that again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.