How can I switch the nvidia driver in use to another driver?

My problem is this

  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
    active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA TU117GLM [T600 Mobile] vendor: Dell driver: N/A
    alternate: nouveau, nvidia_drm, nvidia non-free: 520.xx+
    status: current (as of 2022-10) arch: Turing code: TUxxx
    process: TSMC 12nm built: 2018-22 bus-ID: 0000:01:00.0 chip-ID: 10de:1fba
    class-ID: 0302
  Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB
    driver: uvcvideo bus-ID: 3-3:2 chip-ID: 1bcf:28c4 class-ID: 0e02
    serial: 01.00.00
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa dri: i965
    gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: BOE Display 0x0a89 built: 2020
    res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel UHD Graphics (TGL GT1)
    direct render: Yes

I want to use the proprietary driver of nvidia so that I can use OpenCL in conjunction with it. I tried optimus-manager but after reboot it showed me a screen with a blinking cursor and a black background.

Have you tried running this to see what it shows.

nvidia-inst --drivers

Edit: Also do you have the kernel parameter ibt=off in the default grub command line?

Edit2: I would add the kernel parameter to the default grub command line in /etc/default/grub and save the file and then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then reboot and run

inxi -Ga

Edit2: Not sure if it installed the nvidia drivers and just not showing because of the missing kernel parameter?

This seems to be supported by the latest nvidia driver, so you can install

  • nvidia-dkms
  • nvidia-utils

and kernel headers (if you don’t already have kernel headers installed).

Then you might need to blacklist i915 (=Intel GPU driver) depending on your configuration.

Edit: as Rick mentioned, nvidia-inst should be easy enough to use.

That finally worked. Thank you for your help.