/home didn't get mounted during installation, thanks Calamares installer

Hi there, I was recently initiated into using EOS :slight_smile: I love the experience and theming of the distro. I’ve been using Arch for a couple of years, but it’s my first time using another Arch distro which uses the Calamares installer.

I installed it on my laptop first, as “whole disk” to check it out. So the /home + root are on the same partition afaik. However on a computer which I take seriously, I don’t like the idea of using this kind of partition scheme.

My previous install had these partitions, it’s an 1TB nvme:

  1. 1G FAT32 - boot
  2. 125G EXT4 - root
  3. 805.5G EXT4 - home

I was so confused about having to click colored bars of the disk space in the installer, so I just prayed that it will work. So I picked an option which was supposed to use these 3 partitions and install the system on it, at least that’s what I thought I picked.

Later today when I took a look at my /home I noticed there is only 12GB free space :sweat_smile: so the massive partition for /home was not mounted during the install. I want to reinstall it today.

I would appreciate a few tips on how to make sure that these partitions will get mounted properly via Calamares installer

Thank you :slight_smile:

There is no need to reinstall in this situation. You should just be able to mount your existing /home

Apparently it has already mounted some kind of small home somewhere, so I don’t feel like the install went properly for me. And besides I might need to reinstall it again in the future :smiley: and it would be helpful to know how to properly mount my designated partitions by the installer

I’d really really appreciate tips on how to achieve it during the installation

It is probably just keeping the files in your root. If it is an existing home partition where you are preserving data, you could just copy the data and then mount the volume. That is how I would do it anyway because I wouldn’t want to risk the installer destroying my existing data.(Any installer)

I am not sure what tips to give you. You select manual installation, pick the partition you want to be /home, edit it and select a mountpoint of /home. If you want to keep your data, make sure you don’t select the checkbox to format the partition. There is nothing to it really.

1 Like

There is no data :slight_smile: this is why I am very eager to reinstall the whole thing, it isn’t really a problem. I’ll give another shot at installing it, will reply after I got it

1 Like

If there is no existing data you want to save, make sure you do check the box to format the partition.

I got it :slight_smile: this time I didn’t have an 3rd option which I saw yesterday. But I chose the manual, edited the partitions and chose their mountpoints it was great

Do I need to set FS Label or Flags for boot partition? I see 2 flags “bios-grub” and “boot” I guess I should mark the boot flag?

Thanks!

1 Like

If you have a uefi system you should set the boot flag on your efi partition

1 Like

Yes I have an uefi system, so it appears the correct mountpoint for the boot partition is /boot/efi + gotta check the “boot” flag - I gotta admit, I don’t know why that is so :smile: but I’ll surely refer back to this thread when I need it again in the future

PS. I don’t mind the calamares installer anymore xD I was looking in the wrong place and doing the wrong things the first time. The system installed and works beautifully now, all of that worked out!

Thank you so much for the help! :heart:

2 Likes

Only for reference :nerd_face:
Choosing manual Partition:
2022-09-19_13-43
2022-09-19_13-43_1

uefi Partition fat32 boot flag mounted as /boot/efi
2022-09-19_13-44

Root filesystem ext (p.e) mounted as / no flag
2022-09-19_13-45

home partition (if you want one if not it will be part of the Root filesystem (/)…
ext (p.e.) and mounted as /home:
2022-09-19_13-45_1

result:
2022-09-19_13-45_2

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.