Hidpi still not working

So I’m on the latest EOS installed fresh again this morning. All went well as usually. However, my monitor is a 4K UHD TV so the login screen displayed by SDDM is too small to read.

I have the resolution set to 1920x1080x120hz in Plasma and that works but I’d like the login screen to work. Clicking on the setting for theme/login screen to apply plasma setting still does not have any effect. Every time I reboot I still have the small SDDM screen.

This has been an issue since 5.27 and below. None of the workarounds I’ve found work to make SDDM use 1920x1080 resolution.

Anyone figure this out yet?

Wayland or x11?
If on x11, does running command

ChangeDisplayResolution

help with setting the resolution?

The default for the current Gemini iso after install is Wayland. I didn’t change it.

EDIT:
Operating System: EndeavourOS
KDE Plasma Version: 6.1.0
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.2
Kernel Version: 6.9.6-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 8 × 11th Gen Intel® Core™ i7-1165G7 @ 2.80GHz
Memory: 15.0 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics

I found something that works.

In a file in /etc/sddm.conf.d/
create a file called dpi.conf and it’s content should be:

[General]
GreeterEnvironment=QT_SCREEN_SCALE_FACTORS=2,QT_FONT_DPI=192
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.