Hiding the text after the grub menu

Hello, I wanna hide this text (see image below) that appears after the grub menu.
The problem is also that the text stays on the screen for too long. Im testing EndeavourOS in vm before installing it, so it can probably be because of that. How can I do it? Do I need to hide it or it wont be slow on real computer ?

I also have a question about hiding the grub: I know that I can set GRUB_HIDDEN_TIMEOUT to 0, but I read that it isn’t recommended because I will need the grub menu if the system does not boot. What do you think about this? It is ok to hide the grub ?

These should answers all your questions:

Plymouth: https://wiki.archlinux.org/title/Plymouth
Silent Boot: https://wiki.archlinux.org/title/Silent_boot

Silent boot helped me just hide the Grub menu, and I need to hide the text on the purple background that I wrote about. How can I do this? The text also stays on the screen for too long, which slows down the boot process.

Don’t skip the first link. It can be what you seek.


The text is not slowing your boot time.

It is just telling you what is going on.

The time it takes is the time it takes to load the initial ramdisk.

If you hide away the text, it will take the time it needs to load the initrds anyways.

It is not possible to start the system without loading the initrds first.

1 Like

I’ve installed Plymouth, but it shows the splash screen after the Loading initial ramdisk .... This text is still here. None of the installation methods worked (im using EndeavourOS in vm before installing it):

2.1: There is no mkinitcpio.conf file
2.2: I created a file /etc/dracut.conf.d/myflags.conf with the contents add_dracutmodules+=" plymouth " but nothing has changed

i’m also newbie so it would be nice if you explain to me what I’m doing wrong. thanks.

First, I hope you have not ignored what the other two persons have said.

Second, if it’s just the text you’d like to remove, silent boot should be enough, but you’d only see a black screen until you see your login screen.

This is where Plymouth comes in. It adds the aesthetic of a loading screen of your choice rather than a plain black screen. If you follow the wiki links to a T, you should have a nice Plymouth theme with no unwanted text. Again, though, the text does not delay your boot up time in any way.

Lastly, I may have been the first person to respond to you, but the others are actually more senior and technical than I am. So, again, don’t ignore them, please.

1 Like

ok, now I just want to know if it is possible to hide this text or not ? Of course I didn’t ignore all your messages and installed Polymouth but Polymouth loading screen comes after violet purple Loading ramdisk screen. Is this normal? Will the processes that @pebcak said (load initial ramdisk, initrds) be fast on a real computer (and text will be fast too)? Are they fast for you?

Yes, bare metal (a real device) is always faster as long as you don’t mess up your initial installation or your working system with too many startup scripts, slow configs, etc. (just like when you are using any OS).

Silent boot has lots of options for you to test to get rid of the text you see. And if you want a loading screen, then you add Plymouth. So go through the options from the wiki until you are satisfied enough, but just remember that those messages are just information of what is happening.

Also note that they can actually be quite useful.

1 Like

Why do you want to hide system messages? It is just the operating system telling you what is happening. Do you really want to live in the dark? Since you are a newbie, by your own admission, it may be more helpful to actually see what the computer is doing. Also, the boot process will take just as long whether you see the messages or not. And, if you are concerned about boot time, why would you ever want to install Plymouth (it’s just another set of processes that eat up resources and take time to load)?


Plymouth was my suggestion in case the OP wants some kind of loading screen after removing the messages.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.