Hi, I'm a user coming from Windows Can someone explain to me how to write my problem

My problem is that after installing the distribution, I cannot modify or copy any files from other hard drives

Do you dual boot? Are the drives formatted in windows, or are they formatted with a Linux file system?


Are you sure that you mounted them (by clicking on the drive icon in the file manager or using the mount command in the terminal) ?

1 Like

drives formatted in windows, I don’t use dual boot

I mounted them by clicking on the drive icon in the file manager

Sometimes Windows does a “dirty” shutdown, if you didn’t exit it properly. The remedy is to load the drives in Windows again, and shutdown without any windows open and such, and then boot Linux again.

Not sure if this is what happened here though. It is worth a first try, if you have a Windows machine.

1 Like

I deleted Windows during the installation
Is there another solution

Have you tried with a live iso? Boot one, and see if you can access and modify files from there. If that works, there’s something wrong or missing from your installation.


Thanks and I will try that

It’s by the way the best solution …


Arent NTFS mounted as read only by default when using the drive mount icon?

I think you have to explicitly mount the drive as a read/write drive if youre using NTFS in linux and you need to decide between the new NTFS kernel driver or the NTFS-3G one.

Ideally you wouldnt use NTFS on linux, while its possible depending on what you use the drive for it can be a bad experience. You will also run into issues on the drive becoming “dirty” very often which isnt as easy to fix on linux and would require a check disk by windows. If you have the option i would try to put the data on an external drive, format the drive to ext4 or btrfs, and put the data back on if you wont be using windows.


I am guessing that maybe you need read/write privileges on those USB drives… I is fairly easy when you find it.
I am looking for what I have in mind so be patient.

1 Like

Maybe this can help?

1 Like

I fixed the problem with this command

[memo@memo-esprimop920 ~]$ sudo ntfsfix /dev/sdb1
[sudo] password for memo: 
Mounting volume... The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Attempting to correct errors... 
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb1 was processed successfully.

I got the way to fix it from (Can't Write - Hard Drive is read only in Linux | 100% Solution | Step by Step - YouTube)

1 Like

Welcome to Linux! I guarantee you that after these few teething problems you will not regret deleting Windows. :joy:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.