Hi all! need a little help

Hi all!

i am pretty new to linux, back in 2014-2015 i experiment with Linux Mint 17, Arch (using alot of tutorials), Manjaro and elemantary os. I always liked mint 17 with cinnamon but my older laptop refused to work with linux and had alot of freezes. So i went back to windows 7 and later windows 10. 3 Months ago i made the switch again to Pop! OS 21.04 to see how it runs on my current laptop (Acer Predator G9-793) and it works great so far. I was impressed how linux has grown, even my windows games are working great.

I saw on distrowatch EndeavourOS which i never heard of. So i wanted to try it today in a live session but i ran in a issue. I tried to boot with and without nvidia drivers with no luck. I checked the iso hashes and it is matching too. I have secure boot and tpm disabled.

Any ideas how i can get into live session ?

Your laptop may have Intel Volume management or Raid. Are you able to run inxi -Faz --no-host on your current linux and post the output here with code tags.

1 Like

Hi rick, thanks for your reply.

I used a different usb stick and now i can boot into live. I will also use your command and post the output soon.

@ricklinux, here is the output. I don’t think i am using raid but i might be wrong.

It does have the Raid controller but is set to AHCI so you are good to go if it’s booting on the live ISO.

1 Like

Thanks! already checked and so far i like it. I wonder if it will perform better compared to pop! os. Maybe i will install it on my external ssd drive.

If you install it to your external SSD. Then when booted into it go into the default grub file in

/etc/default/grub

You can use nano or another text editor.

Change the line “GRUB_DISABLE_OS_PROBER=false” to “true” and make sure the line is uncommented and save the file changes.

Then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then you have a fully functioning system on the SSD and it won’t put anthing in the boot loader when you plug it into anything else to run .

1 Like

“Cannot read file data: input/output error” implies the issue lies with the media you are using.

Try creating the boot medium again, and try a different USB flash drive/DVDRW.