Help with Whatsapp Web deleting first Chinese character?

Hello! A few weeks ago I made the switch from Windows to Linux and was recommended EndeavourOS. So far I am having a great experience!

However, after fumbling around with trying to get Chinese input working, I noticed that in Whatsapp Web in particular the first character is glitchy and is not inserted. I made a gif of the behaviour.

Also, I am not sure If I am allowed to link to another forum, but it appears to be similar to the problem this user faced:

I have tried the solution suggested in that post, but it did not work for me.

I am using Whatsapp Web on Firefox, and Chinese input seems to register everywhere besides in Whatsapp Web. Also I am using ibus-pinyin.

Hi there,

I am using fcitx5 and don’t have this problem with Chinese character input in Whatsapp Web in Firefox (just tested).

sudo pacman -S fcitx5-im fcitx5-chinese-addons

should be all you need. fcitx5-im is a meta package, please accept all 4 elements contained therein.

Extensive info in the Arch Wiki.

And please disable/uninstall ibus before dealing with fcitx5. It seems to me that ibus is older and fcitx more current and better integrated in modern desktop environments (I am using KDE Plasma). I ditched ibus several years ago and never had a problem with fcitx.



As you suggested, I have removed ibus-pinyin and installed fcitx6 and it worked after fumbling around with the configtool. Thank you for the suggestion. Do you perhaps also know how to display the current input in the standard top bar in Gnome? That is the only thing that I miss from ibus, together with the on-screen notification when switching input methods. And to be honest, I am still kinda interested in knowing why it behaves like that :smile:


Since I’m not using Gnome I can only G&G (Google and Guess :grin:), but one suggestion is to install the Gnome extension ‘kimpanel’

There’s an AUR package available so

yay -S gnome-shell-extension-kimpanel-git

Ironically this Gnome extension is made by KDE (I guess the name indicates KDE IM-Panel). In KDE Plasma, IM input display in panel works out of the box.

Thanks again! The kimpanel plugin does not show it on the middle of the screen when switching (I did not find anything in the settings for this), but it does show the current layout on the top bar which I asked for!

I remain with one problem only: 门 shows up incorrectly for me. Does that have to do with my systemwide font that I have to change somewhere?

Maybe … what is your system font? Again, I not using Gnome so I cannot investigate further.

Unfortunately there are so many things involved with Chinese input editors that each Linux distribution and each desktop environment seems to behave differently. It’s already a good thing when it works, but ironing out the kinks might involve some trial and error and playing around with the settings.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.