[HELP] This morning I booted up my computer to EOS and I had no internet

This morning at around 8:35 EST, I woke up and booted my laptop to EOS. My EOS install has no internet and I do not know how to fix it. I have tried to restart my network manager and such but it does not work.

Edit: My internet card is Intel Wifi AX200 and Windows does have wifi, Something happened with EOS

More info please :upside_down_face:

inxi -F -az -y1
1 Like

Nevermind. I just rebooted to EOS to run that command and it had internet suddently. I do not know what happened or how I fixed it

Dear Folklore,

You didn’t “fix” it, at least in the usual sense. This happens to all of my computers from time to time and I’ll be darned if I can figure out why it happens or when it’s going to happen. Frankly, there seems to be no rhyme nor reason for it.

But the solution is to merely reboot the computer. Once it is rebooted, you will see that you have your Wi-Fi Internet connection.

It’s a waste of time, but there it is …


P.S. Maybe someone far more knowledgeable than I am can explain it. By the way, it also happens with operating systems other than EndeavourOS, at least in my experience over the years.

Before posting for help, you should always try other kernels and a restart or two in the process.

Glad it’s “fixed”.

1 Like

Did you reboot from windows into EOS?

If you booted into Windows then rebooted into EOS Windows may have still had claim to the WiFi.




Yup good to have fallback kernel. i.e. LTS but have to remember to also install drivers to go along with it i.e. nvidia-lts in addition to nvidia and r8168-lts in addition to just r8168 etc

Also keep in mind that “wifi” (being a local area network) does not provide “Internet” (being a wide area network).

Rebooting your laptop might fix your laptop’s wifi but won’t fix your Internet connection.

In the case of an issue like this in the future is it better to also include thr journal boot logs to see if something failed to start?

journalctl -b

1 Like

Don’t Panic! :scream: