Help me get Openbox to start via ~/.xinitrc please?

How do you call ~/.xinitrc at boot so that it will then run the included xinit content & call openbox-session?

I’ve created the ~/.xinitrc file, but as it stands I have to login (which I’m happy to do, though I remember many years ago on Arch - pre systemd - there was a way to autostart without having to manually login).

Anyway, to continue, as it stands I have to login my user, then call startx, then call openbox from one of the 3 terminals that automatically open when using startx this way.

I can’t successfully call openbox-session this way, it always kills X. But I can call openbox. I’ve done quite a bit of downloading & configuring in openbox at this stage.

I probably should mention that today (as of this writing) I installed the Community Openbox using Calamares. It failed right at the end. I think it was because sda is a Win7 only drive. sdb is for Linux & Haiku.

I managed to get GRUB2 sorted out (BIOS), but I still have the boot problem that this post is about. & no, I’d really prefer not to use a GDM if I can get away with it.

I’d really like to be able to make .xinitrc do what I want it to (which isn’t breaking any rules, it just isn’t popular these days). I should mention that I’ve made ~/.xinitrc executable.

Thanks for reading. :wink:

1 Like

OK, I posted too soon. :slight_smile:

I looked at the Debian website & found a simpler .xinitrc (more like I remember from the old days) than what I read on the Archwiki. So, based on that, I modified it & a couple of boots later I now have success! :smiley:

So I can continue solving the long list of problems that I’ll strike as my new EndeavourOS system evolves into what I desire it to be.

For anyone interested in not using a GDM to start their WM/DE, then a good place to start is by making something like the following ~/.xinitrc & then customising from there. (Well, it worked for me.)
You’ll also have to turn off or uninstall the GDM that you are using.


# ~/.xinitrc
# This file is sourced when running startx and 
#    other programs which call xinit
# As in all Bash/sh scripts lines starting with 
#    '#' are comments
# Always put a '&' at the end of every line but the last.
# as this runs things in the background.
# Also, make sure to make the file executable & 
# I stuck the first line in this file #!/bin/sh as Debian didn't.

# Set background to your favorite pic
##xsetbg -fullscreen /morphix/background.png &

# Start a XTerm
/usr/bin/X11/xterm &

# Start the systems window manager.
# I used openbox like so:
exec openbox-session

# To run xfce4 instead of system default, place a 
# '#' before the previous line and uncomment the 
# next line.
# exec xfce4-session

Anyway, I’ll mark this one solved.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.