Help changing default applications needed

I feel really stupid asking this question now, but I can’t figure it out.
I try to use Alacritty my as Terminal Emulator. I already changed the hotkey, but can’t figure out how to make file explorers or terminal editors use Alacritty instead Xfce-Terminal.

I tried setting the TERMINAL environment variable and fiddling around with xdg- unsuccessfully (although I do not really understand xdg, so maybe using xdg is the right idea but I can’t do it).

Help is greatly appreciated, thank you.

Using XFCE4 you should be able to use the Default applications app to set the defaults.


I installed xfce-settings, did the changes, loged out and back in. Default terminal is still xfce-terminal. But my icon and gtk theme got reset, so it is “working”
Just the opposite from how I wanted it.

Don’t worry. This is an unsolved known issue.


File managers

Some File managers have a specific setting for the default Terminal Emulator (TE) to start when they provide an Open Terminal Here feature.
Others do not provide such function, but provide an Actions feature, where you can write your preferred application manually.
Others use a hardcoded app, while there maybe others that might use $TERMINAL (I don’t know though)


You have found it. Usually shortcuts are customizable, so it’s easy to work it out.

Applications that run in Terminal by default (Terminal=true in the .desktop file)

It depends on the DE.

In general, this issue is mostly dealt with in WM type sessions (i3, BSPWM, etc.), where each of them use their own workarounds, if any. For example, i3 uses i3-default-terminal IIRC, which tries to find the 1st installed TE, from a hard-coded list. A similar thing is done from EnOS utilities (RunInTerminal, IIRC).

Debian based distros use a special app/script/package called x-terminal-emulator.

If you use PCmanFM(-Qt), there must be a configuration in the FM. LxQt does the same IIRC.

Choose and use your own method :person_shrugging: .


Alright, thank you. I have to say, it’s annoying. I mean, the BSPWM guys somehow managed to make xfce-terminal the default? Why can’t i change that? Or does xfce-terminal make itself the default terminal? Still marking your post as solution, since it provides a good overview for everyone with relating problems.

There is no such thing as default terminal, as I explained.
Think about how you try to invoke a default terminal. Then, read again my previous post and ask yourself again what you want to happen and when.
If you can’t figure it out, ask a better question here, so you might get what you want, or what you need. :wink:

1 Like

Please show exactly, using the actual code or settings in full detail, what you have tried so far, and how you are trying to use those. All details are necessary for troubleshooting.

It’s the termimal that is launched when I open neovim from rofi, or when I open the hotkey overview from polybar. At the moment, both open xfce-terminal (and then open neovim/less in it). And i want this terminal to be Alacritty.

Setting the TERMINAL environment variable:

$ printenv | grep -i terminal

I did not understand xdg enough to change anything.

Not sure how default apps are handled in bspwm (since I’m not using it), but desktops use mime stuff. It may or may not work with WMs too. Hopefully bspwm experts help out here.

Anyway, this command shows you info about how to manage mime data:

man xdg-mime

Usually a file manager is able to make file-to-app assignments.

Rofi acts like the usual Applications menu/launcher normal DEs have.
For this task/case, check rofi configuration and manual.
IIRC rofi includes command line setting for the preferred TE.
man rofi:

Specify which terminal to start.

rofi -terminal xterm

Polybar has modules that usually run some command. Find your relevant module/command and modify, if possible.

IIRC, with this env var set, you can use it in polybar module commands successfully (as $TERMINAL).

1 Like

Thank you, everything worked.

1 Like

That’s great.
I would appreciate a description of what you have done to make it work, since I only pointed at directions :person_shrugging: :wink:

  • Changed the keybindings to run rofi with --terminal alacritty
  • Changed the polybar config to use alacritty when executing the help command

However, just switching from xfce-terminal to alacritty didn’t work for polybar, I needed to remove the quotation marks: alacritty -e less /home/$USER/...

1 Like

Did you try using $TERMINAL?

Polybar has some limitations on the accepted values and format for the keys/commands.

You might want to read polybar wiki and man for more in depth info. :wink:

$TERMINAL does work

1 Like

just out of curiosity have you tried removing one of the Terminals in this case xfce4 since you wish to make alacritty your default.

This wouldn’t have worked

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.