Headphones Not Working Please Help

I know I posted this topic before but this is a different laptop. My wired headphones worked on my previous linux distro. They worked on the EndeavourOS live image. They worked if I install offline before update if I update they stop working. They do not work on online install at all. I have tried alsamixer to make sure they were not muted. They were not muted. I have disabled quick boot. In pulseaudio volume control it shows the headphones are connected and the meter shows sound is being played. Yet there is no sound comming out the headphones

I have also tried bluetooth headphones and had the exact same experience.

I really want to use EndeavourOS on all my machines.

here is my system specs
inxi -Fxxc0

  Host: theremper-gl503vd Kernel: 5.7.12-arch1-1 x86_64 bits: 64 
  compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 
  wm: kwin_x11 dm: SDDM Distro: EndeavourOS 
  Type: Laptop System: ASUSTeK product: GL503VD v: 1.0 
  serial: <superuser/root required> 
  Mobo: ASUSTeK model: GL503VD v: 1.0 serial: <superuser/root required> 
  UEFI: American Megatrends v: GL503VD.310 date: 04/29/2019 
  ID-1: BAT1 charge: 54.8 Wh condition: 54.8/64.4 Wh (85%) 
  volts: 5.3/15.2 model: ASUS A32-K55 serial: N/A status: Full 
  Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 44817 
  Speed: 3494 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3527 
  2: 3719 3: 3464 4: 3595 5: 3592 6: 3435 7: 3633 8: 3435 
  Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:591b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: nvidia v: 450.57 bus ID: 01:00.0 chip ID: 10de:1c8d 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-7:4 chip ID: 13d3:5666 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: intel,nvidia unloaded: fbdev,modesetting,vesa 
  alternate: nouveau,nv resolution: 1600x900~60Hz s-dpi: 97 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
  Sound Server: ALSA v: k5.7.12-arch1-1 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI port: d000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: b0:6e:bf:50:13:ae 
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel 
  port: d000 bus ID: 04:00.0 chip ID: 8086:24fd 
  IF: wlan0 state: up mac: f8:94:c2:25:08:5a 
  Local Storage: total: 465.76 GiB used: 8.39 GiB (1.8%) 
  ID-1: /dev/sda vendor: SanDisk model: SDSSDH3500G size: 465.76 GiB 
  speed: 6.0 Gb/s serial: 180243424674 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 bus ID: 00:17.0 chip ID: 8086.282a 
  ID-1: / size: 448.50 GiB used: 8.39 GiB (1.9%) fs: ext4 dev: /dev/sda2 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/sda3 
  System Temperatures: cpu: 63.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 236 Uptime: 26m Memory: 15.52 GiB used: 1.25 GiB (8.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.1.0 Packages: pacman: 1002 
  Shell: Bash v: 5.0.17 running in: konsole inxi: 3.1.05

I really really hate to reply with this, but I had a similar issue about a week or so ago. I honestly can’t for the life of me remember the specific action I used to solve it. I know I discovered the solution at https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting

Like I said it pains me greatly to link to the ArchWiki and I truly apologize. I figured since you have not had a reply yet at the very least me posting may bump your topic so someone else sees it. I’m sorry I cannot be more helpful.

1 Like

Have you tried using linux-lts instead?

I just tried lts kernel still no audio. Thank you for the advice tho

Could you tell us what headphones you’re using. That may be helpful info…

I was going to jump in here with helpful advice - but when I looked more carefully at the inxi posting, the suggestion I though of was invalid :grin:

Perhaps there is something in the pulse-audio panel that might help - there is access to some settings there…

thank you for the link. I tried a few things there still no audio

I am just using some cheap ear buds. I have tried a couple of different pairs

I beleive I have tried all the different settings in the pulse-audio panel the little meter shows there is sound being played but there is none. Sound does play out my speakers tho

Check if the right modules are loaded.
I have faced sound related problems where the module wasn’t loaded (although it wasn’t related to playback.)

Also, I don’t know how frequently this is suggested on Linux forums, but did you try rebooting your system?

1 Like

I believe the right modules are loaded. I have rebooted my system after trying each new thing, just in case. still no audio. but thank you

1 Like

Have you installed plasma-pa? That’s the KDE applet for pulse audio.

Try this command. It will do nothing if it’s already installed.

sudo pacman -S --needed plasma-pa

Yes it was install by default. My speakers work just no headphones and I know the jack works becuase if I install a different distro it works. and it works on the live media. I think it has something to do with a pulse audio update

I am still having this problem do you guys have any other ideas

I’ve read this thread for a while, but since all things seems to be excluded and headphones themselves…

Maybe you can try JACK (not headphones jack, but program) and bypass pulseaudio completely to see if it works and if it will play - then it’s some problem with pulseaudio and we can report it…

I can walk you through JACK installation and basic use, if you want to try :slight_smile:

Thank you for the quck reply. It woiuld be great if you couild walk me through the process of installing JACK.

1 Like

Here’s basic setup…

Install those packages:


Launch Cadence and do it’s most basic settings (to route all audio through JACK):

JACK Settings
[x] Auto-start JACK or LADISH at login

ALSA Audio
Alsa -> PulseAudio -> JACK (plugin)

[ ] Auto-start at login

[x] Realtime

[x] ALSA
    [x] Duplex Mode !
    Device/Interface - your audio card
    Sample rate - 44100 kHz
    Buffer size - 512
    Period/Buffer - 2

System settings - Audio
[x] JACK sink (PulseAudio JACK Sink)

Smaller buffer size - obviously smaller will be latency, but if you just listen and don’t create music - it should be safe starting value (although outcome heavily depends on Audio hardware, usually you should aim for as small value as possible, which doesn’t introduce crackles / xruns)

Inside Cadence there is Tools - Catia - here you can route anything to any connection like an octopus :slight_smile:

Now, you start for example VLC, go to Tools - Preferences - Audio - Output module and choose JACK audio output, this means that you will completely bypass pulseaudio and ALSA and use jack directly.

Now, close VLC and open any audio file with it see if there is a sound!

If there still won’t be sound you can just remove those packages, this should bring you back to usual pulseaudio setup…

Hopefully it will help!

P.S. If you’re interested, JACK is for proaudio mainly, you can read more here https://jackaudio.org/


Thank you for the help. I must have done something wrong. I had no audio at all even through my speakers after a reboot. I uninstalled the files and my speaker volume came back just not my headphones thank you anyways

Now, you start for example VLC, go to Tools - Preferences - Audio - Output module and choose JACK audio output , this means that you will completely bypass pulseaudio and ALSA and use jack directly.

You must have missed something along those lines, or:
Driver - Device/Interface - Choose your audio card output

Well…Anyway, other than trying JACK i’m completely out of ideas :slightly_frowning_face:

I know I posted this some time ago but I just found a solution and thought I wouild share it. It seems that a small change a change in patch_realtek.c in the kernel and updated lts kernel is the problem. This affects ASUS GL703GM, GL703GE, GU502GW, GL503VM and GL503VD Laptops. The fix I used is to add “options snd-hda-intel model=headset-mode” to /etc/modprobe.d/alsa.conf then completely shut down my system turned it back on and now my headphones are working