Headless server Raspberry Pi 4

I try to install EndeavourOS on a Raspberry Pi 4, with only an ssh connection. But when I try to connect to the ssh server, I get no connection. When I control with nmap for an open port, port 22 is closed. What can I do about this?

Thank you :slight_smile:

Welcome in our community :slight_smile:

I haven’t try EOS on any of my pi, raspbian let’s you edit a config file directly on the sd card. Did you look if you can do this ? If you can’t you need to connect your pi to a monitor/keyboard.
For starting the ssh daemon each time your pi boot:

sudo systemctl enable sshd.service

And if you want to try before setting it in your headless spot:

sudo systemctl start sshd.service

take look here …

1 Like

Just a thought - what advantage is there to install EndeavourOS ARM to RPI compared to ArchARM when the device will be only a headless server.
I thought that the advantage of EnOS is just GUI installer but everything else is basicaly Arch. :thinking:


@pudge do great job set it up for usr on EOS , if usr just use ArchARM usr need set up all them self . Pick your poison :blush:

1 Like

Also did arch can have control on the gpio ? I know it was missing on “raspbian” 64bits version.

Yes, he did great job :star_struck: but still it is set up with an intention to run full graphical desktop environment. For headless I would expect significantly less. :smiling_face:

1 Like

the choice is there for full graphical desktop ( if usr want ) we all have different need/idea on server use . he make it easy for EOS usr. (that just my opinon )

" https://discovery.endeavouros.com/category/arm/ "


@Shjim fair enough. :wink:

I do not remember if the service was enabled by default but in thory it could be enabled without running the system directly.

Note: this may break the RPi system. So backup accordingly.

Connect your SD card to your (main) computer.
Mount the root partition of the sd card system - you can check sudo fdisk -l which one it may be.

sudo mount /dev/mmc0blkwhatever1 /mnt

Add symlink to enable ssh service. (check first if it already exists in /mnt/etc/systemd/system/multi-user.target.wants/sshd.service to make sure if this approach is really the root cause of the problem).

ln -s /usr/lib/systemd/system/sshd.service /mnt/etc/systemd/system/multi-user.target.wants/sshd.service

update /mnt/etc/ssh/sshd_config file to your liking
sync and sync again (you can never be too sure :wink:)

sudo umount /mnt

Put SD card into the RPi and see if that works.

The connection may be also blocked by firewall (I do not know the default setup) in which case I do not know how to change it without booting the system.

edit: This assumes you already have the system installed on the SD card. :wink:

If one follows this guide to install a headless server, there are absolutely nothing graphical installed. Having used the following guide:

I ended up with this neofetch

Neofetch shows
the os as Arch Linux ARM aarch64
the Packages as 211 (pacman)
the memory used as 91MiB

If I remember correctly, yay and pahis are the only two included packages from the EndeavourOS package repository.

This is about as stripped as a headless server as can be. Not even x11

Then as @Shjim suggeted, there are seven how-tos for setting up your headless server with Samba, minidlna, etc.