Having weird freezes recently

Recently I seem to have my laptop completely freeze with no apparent reason. This seems to only happen when computer is inactive and goes to “sleep” or “hypernation”. It also seems to happen every other or third boot I do.
All of these times the screen is completely blank, keyboard lights up, but seems not to do anything. I can’t even get TTY to work when this happens.

Here is my inxi:

I uploaded my journalctl to my gooogle drive, because it is massive and was too big for pastebin.

I did look through the journal to see if I would spot anything, but my eyes are untrained for this type of work.

If this is a duplicate of another post I am sorry, but I really haven’t seen what is the exact problem in order to search it.

This is relatively recent (maybe a week or so) because at first I didn’t notice the pattern.

OK, I got two freezes this morning while starting the computer. I checked the logs again and noticed some amd stuttering. Short search recommended BIOS update.
I have updated the BIOS and I am currently in the process of validating if that has resolved the issue or not.

1 Like

I’ve had the same thing happen a few times for like a week now. Most of the time after the grub screen, but it happened once when the screen turned off. I’m on AMD too(5700g).

What stuttering you noticed? In the logs or while using the system?

1 Like

It was marked as a stutter in the logs, followed by a reset by me.

1 Like

Not sure if this is related but I put it here anyways:

I’ve also experienced occasional freeze lately on an AMD-based laptop.
Also rebooting hangs for me at some point and I have to use the power button.

I haven’t yet looked through logs :blush:

1 Like

there was another stutter issue a few months ago, but that didn’t really show anything in the logs, it was because of amd fTPM. Let us know if the bios update helped, the bios for my board is still in beta.

1 Like

that could be the same cause as in the thread here. The problem has been there for about a week, just like yours.

1 Like

After few inactive sessions today, I haven’t experienced any freezes. I want to wait until tomorrow for further testing until I mark it as solved, but as it seems to me the BIOS update seems to have fixed my issue.

For those who are interested, then the error I notice is this one

tpm tpm0: AMD fTPM version 0x3004900000005 causes system stutter; hwrng disabled linux

And the solution I found by googling this issue

1 Like

I am going to mark this thread as solved. After multiple inactivity and turning the computer few times off and on again, I have not experienced another freeze.
Updating BIOS solved my issue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.