Having issues getting Secure Boot / UEFI / GPT boot working right. Any ideas?

Then, don’t disable CSM. Use the “UEFI only” setting in those other settings.

I guess. Doesn’t change the fact that it can’t load up GPT bootloaders

Are you sure the drives are GPT? If you installed with Mbr it’s not GPT.

Are you saying that it’s impossible to burn a GPT liveUSB if I’m in an MBR OS? I don’t think you are but I don’t know what you mean

No that’s not what i meant. You posted the image that showed the drives are not GPT partitions but dos.

Edit: Have you checked the Bios version of your board?

I’m on 3.90.
Kinda confused on whether or not I can upgrade… I have a Ryzen 5 2600, one of the Pinnacle Ridge processors.
It’s on the supported processors list, but it’s also in a warning not to try updating firmware if you have this processor?

Dont update it then . Try setting your disks mode from RAID (if it is set to RAID) to AHCI in the BIOS.

I’m not sure either since i had another user update an X470 Taichi Ultimate and his system won’t post. The information is very confusing on their website.
If you look at these pages you’ll see what i mean. Looking at CPU support for Ryzen 5 2600


Then it shows this page.


I think before i would try updating it i would contact Asrock and ask them what Bios version this board will support with the Cpu you have. I don’t want to see you have the same issue of the board not posting. This is unusual to me as most motherboards i have dealt with always have the latest bios version and it supports the Cpu it was designed for and also can add features to update to newer Cpu plus other updates that could be security related or other.

Edit: The other user didn’t have a Pinnacle Ridge Cpu either. It is a Ryzen 3700X.

Based on reading through all the responses, have you tried disabling TPM? I’ve had that occur before (albeit they were Dell devices/motherboards), where it doesn’t see any disks. TPM can be a right pain. Some motherboards it works and with some distros it works, but more often than not, it doesn’t.

The other thing to check in your UEFI/BIOS settings is to make sure all drive types are enabled. I know it might seem silly, but I’ve seen that happen before.

Not sure I fully see where the problem is here. Based on the output you shared, the only GPT partition table is on your Ventoy USB. Like @pebcak said, all your other ones are DOS.

Can you boot into the live ISO in legacy mode and reformat the disks and then disable legacy mode and reboot?

If anything, it somewhat seems like there may be conflicting settings in the BIOS. Most BIOS have a place where you can reset everything to manufacturer defaults and start over again. That’s another option to consider. I have 2 ASRock board in use right now and just sold a third about a month ago and never had problems with them recognizing drives or Linux.

I agree with @ricklinux, BIOS updates can be tricky and I’ve always found ASRock to be a bit odd about updating, they always give warnings. I’ve never had problems (thankfully), but many many people do. ASRock can even be picky about the USB stick you use. I have both read and experienced with the board I just sold, that updating the BIOS to a newer version to accept a newer CPU (in my instance it was on an Intel board, not AMD) then prevented the board from recognizing an older CPU.

  • use Secure Boot ==> set to Disabled
  • disabled CSM ==> Use “Both UEFI and Legacy”. No need to disable CSM, unless nothing else works.
  • enabled Above 4G Encoding ==> I have this disabled. Do you need it for some reason? Else, disable it.
  • fTPM enabled ==> Absolutelly Disable this. It may also need to “Clear keys”.
  • Drives (storage) may have an option for UEFI or Legacy. Set to UEFI.


  • After you modify BIOS settings, save and boot. On failure, power down the PC with the power button, don’t reboot.
  • On boot, use the Quick Boot Menu hotkey (read MB manual, or the Logo/initial PC boot screen, usually at the bottom). Choose a UEFI entry from the list. If several partitions are listed, try all of them one by one.
  • If all fail, install EnOS in Legacy, on a GPT drive (you can even convert an MBR disk to GPT, with sgdisk). Make sure you create one esp partition (FAT32 1GB), and mount it at /boot, and an unformatted partition with flag grub_bios. After a successful installation, you can install grub for UEFI, and then change BIOS to UEFI only to see it. Final touch can be done from a Live ISO (any Arch-based distro) with arch-chroot.

Archwiki has everything you might need to complete all the above.
FWIW, I have just done it for my upgraded Hardware :person_shrugging: .
It seems that newer hardware/BIOS have become too complicated and with very few (to no) info provided.

Sorry about the wait. Been a busy week.

Just checked, I was in ACHI. Think I always was.

I emailed them a couple weeks ago and still got nothing, unfortunate :\

Still catching up to the rest. Trying without TPM next…

Based on reading through all the responses, have you tried disabling TPM?

Trying with fTPM disabled… Nothing. Black screen.

Make sure all drive types are enabled.

All drive types are enabled. I can boot from MBR flash drives.

Honestly? I’m not stressed over it. This is a new setup, and I wouldn’t have noticed at all if a friend hasn’t asked why I’m not using SystemD-Boot. Which I can’t answer.
I probably shouldn’t care, but, I can’t help but wonder why I can’t get the latest software working right. I did have modern GPT stuff working right a while back, I mean, I’m migrating from Win11, which required SecureBoot and all that…

It worked this time. I think it was disabling fTPM. Can you elaborate on why you thought that would do it?


It must be a crappy Bios implementation because on my system i have Secure boot disabled but TPM and fTPM are both enabled. My drives are set to UEFI only. I have CSM disabled although i can set Both UEFI & Legacy. I just prefer it this way as i don’t use legacy. Modern systems are UEFI and that is what i only use.


Nothing more than this explanation:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.