Having Issues Crashing to Login

First time using an Arch-based distro, something I’ve been wanting to do for a long time. I read a little about the different desktop environments and after coming from using ElementaryOS for a long time and then recently switching to Ubuntu Budgie, the option for Budgie interested me about EndeavorOS. After reading more, I learned the Plasma DE is the preferred option for most, and so that’s what I chose on install.

I was having a strange bug where every time I logged in, it would crash back to login (it was actually doing a “soft” reboot of sorts, crashing everything). At first I thought it was a bug with the DE, so I plugged the installation media back in and installed with Budgie. I actually like Budgie and will probably stick with it, but I found that the crashing was caused by my second monitor being plugged into my laptop.

My laptop is equipped with a GTX1050 (mobile) graphics card and intel onboard graphics. I’ve done some searching already and I can’t, for the life of me, seem to find a resolution to my problem. I’m thinking there needs to be some configuration for multi-monitor support, but I’m not sure where to start. Is it my graphics card that’s causing this or is it some dependency required in Linux in order to support the dual monitor?

This is my first time posting, hopefully I’m in the right place.

Hello @thekhrazy
Welcome. Did you happen to install the nvidia drivers when you installed EndeavourOS? Could you post the output of:

inxi -Fxxxa --no-host

You may need to install inxi first.

yay -S inxi

Most likely you need to set up your hybrid graphics.

1 Like

I did select to install the nvidia drivers, but I know this can be funny in Linux a lot of the time, so feel free to correct me in what’s going on.


Kernel: 5.8.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=a48a5baf-db28-4354-92e9-0eefa1be8ca1 rw quiet loglevel=3 
  Desktop: Budgie 10.5.1 info: budgie-panel wm: budgie-wm 
  dm: GDM 3.36.3, LightDM 1.30.0 Distro: EndeavourOS 
  Type: Laptop System: LENOVO product: 81FV v: Lenovo Legion Y530-15ICH 
  serial: <superuser/root required> Chassis: type: 10 
  v: Lenovo Legion Y530-15ICH serial: <superuser/root required> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN 
  serial: <superuser/root required> UEFI: LENOVO v: 8JCN54WW 
  date: 06/15/2020 
  ID-1: BAT0 charge: 52.0 Wh condition: 52.0/52.5 Wh (99%) volts: 12.8/11.3 
  model: LGC L17L3PG1 type: Li-poly serial: 1980 status: Full 
  Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: D6 L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 801 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Lenovo 
  driver: nvidia v: 455.23.04 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c8c 
  Device-3: Lite-On Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-6:4 chip ID: 04ca:7070 
  Display: x11 server: X.Org 1.20.9 compositor: budgie-wm 
  driver: intel,nvidia unloaded: fbdev,modesetting,vesa 
  alternate: nouveau,nv display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Sound Server: ALSA v: k5.8.12-arch1-1 
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Lenovo ThinkPad E595 driver: rtw_8822be v: N/A 
  modules: rtw88_8822be port: 4000 bus ID: 07:00.0 chip ID: 10ec:b822 
  IF: wlan0 state: down mac: ce:2b:f6:a4:02:fa 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel modules: r8168 port: 3000 
  bus ID: 08:00.0 chip ID: 10ec:8168 
  IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: e8:6a:64:2b:9f:0f 
  Local Storage: total: 931.51 GiB used: 8.04 GiB (0.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: WGS20RHQ rev: LXM3 scheme: GPT 
  ID-1: / raw size: 630.27 GiB size: 619.37 GiB (98.27%) 
  used: 8.01 GiB (1.3%) fs: ext4 dev: /dev/sda5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 56.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 265 Uptime: 39m Memory: 7.65 GiB used: 1.33 GiB (17.4%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 956 lib: 269 
  Shell: Bash v: 5.0.18 running in: gnome-terminal inxi: 3.1.07

It looks like the Nvidia is installed but it’s running on the Intel so probably when you hook the other monitor that is what is causing it. I’m not the expert with Hybrid graphics set up. I can run people through it but there are variables such as whether you want to use optimus or bumblebee? This is in order to switch graphics from one to the other. You probably want the Optimus-manager for GTX 10 series cards.
Normally it is recommended to use the nvidia-dkms version.

Can you run:

Edit: After running that could you run a test?
nvidia-installer-dkms -t

This will just run an install test and see if the install will proceed without any errors.

It gave me an output saying the driver is supported by nvidia-installer-dkms. I’m running dkms right now and will report back once finished.

If you could post the output of that command when it finishes the test and just put three tilde ~~~ before and after the output you post.

I ran the command and it advised me to reboot. I rebooted and it fails to launch the kernel, I think?

Essentially I power on and it starts kernel in top right and then says clean / blocks etc and then it blanks to a white underline in the very top right and hangs. I’m back on the installation media.

It should have only run the test as i gave you the command for test only.

nvidia-installer-dkms -t

Edit: You do this first to see if it will install without errors. Then to install it you would run
sudo nvidia-installer-dkms

Edit2: Then after if all went right you would install the Optimus-manager

I’m essentially doing another fresh install to give it another shot. I’ll post once done

I didn’t attach the -t the first time I did it because I didn’t catch your edit in time. It just recommended I did it, so I did and then rebooted and the system just decided I wasn’t allowed to have fun anymore lol.

Sorry about that. I was kind of waiting for a response and then i decided to add that after. Anyway the test is run first without sudo and usuing the -t option to get a test install to show if there would be any errors. It doesn’t make any changes to your system in test mode.

Then you would hopefully have a successful install after that if it say’s no errors. Then after you just install the optimus manager and enable it according to the instructions. If you are using Budgie again then.

yay -S optimus-manager


Check status

systemctl status optimus-manager

To start and enable it run (if it is not running):

sudo systemctl enable --now optimus-manager

All of the instructions are above in the wiki.

Awesome, didn’t know that would’ve related to the multi-monitor support, but I do all of that and hopefully we’re in the clear! Thanks for your help

With the optimus manager you should be able to switch graphics and also set up dual monitor. I’m just not up on the Hybrid setup as i mostly use desktops. If i get a new laptop I’m looking at Ryzen with AMD dedicated graphics.

Edit: Also keep in mind if you use Plasma or Lxqt or Deepin it’s differnet and also Gnome has another package too!

I should have given you this first.

I also read on the github page for the Optimus-manager that it automatically logs you out when you switch GPU’s so you need to be aware of that and save your work first it say’s. You may find this isn’t the solution you want maybe? I’m not sure like i say i don’t have any laptops with hybrid setup. There are others here that do so don’t be afraid to ask if this doesn’t suit you.

I just tried again from a fresh install and installing optimus manager doesn’t work following the guide exactly.

This is also my first time using “yay”. I tried it a different way by installing using the instruction from the creator on github, but those didn’t yield positive results either since it has you take it from the AUR repository, and since this is my first time in Arch, I have no idea how to work it at all.

I’m just very lost and I thought this would be an exciting branch for me. It just seems like I picked a bad machine to try it for the first time which is frustrating because I’m big on lost time and feel like this was just a huge waste.

What is the brand of the second monitor? The display port is connected to nvidia correct??

Does this Optimus-Manager work with the nvidia-dkms or does it need to be only the nvidia proprietary drivers? This is something I’m not 100% sure on?

Edit: Okay i read it over again and it does state:

On Archlinux, you can use the packages nvidia or nvidia-dkms.

dkms is you use other kernel :slight_smile: like linux-zen as example :slight_smile: optimus-manager is kinda switcher

Thanks. I understand that part but in one section on the wiki it stated:

For this you will need the proprietary NVidia driver installed. But, i have read the actual Git-Hunb page and it states as above that you can use nvidia or nvidia-dkms. I just wanted to make sure i wasn’t giving bad information.