Hardware check make my pc turns off

Hi there…
Thank you so much for this great OS you putting out there am really excited to try it out.
Actually i did tried it out but unfortunately it didn’t work with my hardware.
I bought a new laptop which is Asus Strix GL703GE it has an Intel core i7 8th gen CPU and a NVIDIA GTX 1050ti graphics.
The issue is every time i boot too the OS the laptop shutdown when it check the hardware. I have the same issue with Open-Suse and Fedora.
So if you can help i will be very thankful.
Regards from Iraq with love.

When you say it shuts down every time you check hardware what is it that you are doing? Are you using inxi to check hardware? Please explain in more detail. Does it stay running if you just boot it up? Can you browse the internet without it shutting down?

it happens when i try to install it. i put the usb stick and boot and when it checks the hardware the pc just suddenly shutdown.

Do you get to any boot menu?

i get to the boot menu and i choose the first option too boot to Endeavours after that in a couple of seconds it’s turns the pc off on me. I have the same issue with Fedora and OpenSuse. for now i managed to install several Ubuntu based Distros and Native Arch with out any issues

So you have installed Arch before on this laptop the Arch way? Or another distro based on Arch? The first boot menu you are talking about is after it’s installed? This is a live ISO. So you downloaded it and created a live ISO? What did you do it on another Linux computer or Windows or what? What did you write the iso with? I use Etcher.

  • yes i did install Arch the Arch way but it was buggy and when i installed NVIDIA drives it crush and never boot again.
  • the boot menu of a live iso what i talk about.
  • yes i download it and created a live usb with both etcher and dd too get the label named correctly.
  • i did it on Ubuntu Mate i dont have any windows pcs.
  • etcher and dd been used to write the usb.

It is obviously your video card is the problem so you need to install it after with the Nvidia installer once you are able to. Have you tried nomodest and if that doesn’t work. Try modprobe.blacklist=nouveau. Do you know how to do that in the boot menu?

1 Like

actually no i didn’t try to do that and i don’t know how to do it.

Here is a link for an Nvidia enabled iso. Please try it.

thank you so much for your time and your support i will try it and give my feedback.

I solved the issue by typing the letter E on the live usb boot menu and on the end of the line i added the following:


now i can say proudly “By the way i use ARCH” :slight_smile:

@ricklinux thank you very much for your help

Awesome. Did you use the final ISO or the link to a beta ISO for Nvidia? That’s exactly what you needed to do.

I have an older Dell computer that required grub be modified with the addition of “pcie_aspm=off”

may we could add this to an extra boot menu entry …

1 Like

because of my slow internet connection i couldn’t download the iso that you gave me. so i used my old iso and solved the problem with modeprobe.blacklist.

actually that will be a great solution.