GUI freezes randomly

I had the issue lately, that the GUI freezes randomly.
I’m not shure if it is the GUI only or the whole system.

But one time it worked after waiting half an hour or so again.

So now I want to find the cause of this freezes.

see system logs, use a live system to check for hardware issues, make memory testing and hd smart evaluation

How can I see the systemlogs?

Memory testing is running in the moment on this system.
Smart Data is a good pont, I’m going to looking at it.


So I should take all logs with the log-tool?

Here are the smart data:

SMART/Health Information (NVMe Log 0x02)
Critical Warning:                   0x00
Temperature:                        40 Celsius
Available Spare:                    100%
Available Spare Threshold:          10%
Percentage Used:                    0%
Data Units Read:                    15.557.608 [7,96 TB]
Data Units Written:                 7.416.288 [3,79 TB]
Host Read Commands:                 77.447.190
Host Write Commands:                71.374.799
Controller Busy Time:               306
Power Cycles:                       432
Power On Hours:                     87
Unsafe Shutdowns:                   61
Media and Data Integrity Errors:    0
Error Information Log Entries:      0
Warning  Comp. Temperature Time:    0
Critical Comp. Temperature Time:    0
Temperature Sensor 1:               40 Celsius
Temperature Sensor 2:               42 Celsius

Error Information (NVMe Log 0x01, 16 of 64 entries)
No Errors Logged

Memory Test, didn’t find any issues :+1:

Most likely not a hardware-issue then. So you need to research your installed software. Post info about that, what software, which DE, ETC. It can easily be done via the inxi-command in the above link.

Here is the output of:

inxi -Fxxc0z | eos-sendlog
journalctl -b -0 | grep fail | eos-sendlog
journalctl -b -0 | grep error | eos-sendlog

I saw some logitech driver messages, with normal jornalctl:
I added them:

journalctl -b -0 | grep Unexpected | eos-sendlog

So do you need some more logs and which?

Ok, thanks.

Here’s an idea: Run journalctl -f in a terminal window, and see what happens. Keep it open until the freezing occurs. In that moment in time, it will tell exactly what’s wrong.

Another idea: Create a new user, see if problems persist. If they don’t, you just have to selectively clean your ~/.config and perhaps ~/.cache to get rid of some older plasma settings.

Since when has your system began to freeze randomly? What updates came in before that? Was there a major KDE update involved?

It was a long time ago.
It didn’t freeze some time, and now it starts again.

I will use your trick with journalctl -f and see hopefully what the issue is.

When it freezes it freezes with no load, like surfing on the web or doing light tasks.
Under heavy load it never freezes!

1 Like

So now it freezes again.
I can’t switch to a console with ctrl+alt+F3…F7

The System seems runing, I tried to ssh into it, but it refuses the connection.
I also can Ping th Systems IP Adress and get a reply.

Is there any other way to get to an console to save the logs?

This was happening to me, too. I was using either the current kernel at the time (6.3.x) and the Zen kernel. Didn’t matter which one I was using. Happened mostly while consuming YouTube videos. No mouse input, no keyboard input. Hard graphics freeze but the audio would continue. I would have to force a reboot by holding the power button.

I figured it was probably something to do with the nVidia graphics but didn’t have the time or patience to investigate.

I have an AMD Card.
What CPU do you have?

I thing the issue ist the AMD Ryzen 3800X, I’m test some other Bios Setting in the moment to validate.

1 Like

This should not be happening. I bet it has to do with some settings changes you have made. I have the Ryzen 3800X on KDE and using Btrfs and it runs flawless both on x11 and Wayland with an amd RX 590. Have you updated so that you have the latest mesa?

Edit: I see there is a Beta UEFI Bios update that has the latest AMD AGESA. You have the Bios version just before that. I am running the latest on an MSI board but mine ran fine on every Bios version. I have updated it over 13 times or more. No issues running on amdgpu.

Edit: I should have noticed you are on Plasma. :wink:

I have all the latest updates from EndeavourOS that should include mesa.

I think it is the old issue again with “low current idle”.
This should be fixed in newer Linux kernels.
I set it to “typical current idle” now.

I had no issues with this Uefi Version in the past on Linux Mint and EndeavourOS.

It is in the Plasma category because I first thought it was an Plasma Issue. You can move it in to another category if you want :slightly_smiling_face:

I don’t know what this is? I have no issue with Ryzen 3800X but i don’t try to change settings for cpu either.

I think it was this bug Here:

And the Uefi Setting to “typical current idle” in the CPU settings was one of the many solutions to this bug.

It should be fixed in newer Linux Kernels

I use mostly default settings in the Bios. I don’t use sleep mode or hibernation on my system. I only use memory profile and i i set the 65 watt verses 100w.

I didn’t used any sleep mode.
The system freezed by light load :wink:

I’m not talking about any sleep mode. I just mean have you changed settings in the Bios besides the normal things that need changing such as disabling secure boot?

I think we should move this to the hardware section in the Forum :sweat_smile:

I can post the Settings later this day.
But I think I only turned Secureboot and TPM Off and XMP and rBAR on :thinking:

I Run These settings since the First day, without any issue. The freezes happen since Kernel 6.2 or 6.3 I think.