GTK graphical bug with small green pixels

System log
I have this graphical bug within all GTK applications where sometimes these small, usually green pixels turn up all over graphical UI elements. It looks like this:
The only program where I’m consistently able to reproduce it is within Emacs, where it shows up whenever there are any inline images or graphics and also on the modeline if I use powerline. It’ll only go away after I switch my theme via customize-themes. In other programs it’ll just randomly show up. I’ve had this bug show up in pretty much every single GTK app I use, like gparted and Gimp. In Gimp it will reliably show up in any text entry boxes and in the brush selection, for example. I’ve had to deal with this bug for quite a while (at least half a year, I think, when I was still using Manjaro). When I tested endeavour on a VM this issue simply didn’t show up, so I suspect it might have something to do with my hardware. It also doesn’t seem to appear on certain earlier versions of GTK, since this only started happening after an update and I can run portacle, which includes an older version of Emacs, without any issue.

Doesn’t feel like a theme issue? If another theme doesn’t have this behavior… use that one, or find one that is fine.
Or I misunderstood, so explain more about your used theme and other themes.

You’re misunderstanding this. The themes I was talking about are emacs themes, not GTK themes and the graphical bugs will show up when I start Emacs no matter what emacs theme I have selected, it’s just that if I switch emacs themes multiple times it’ll go away from Emacs until I close or resize the window, but not from any of the other GTK programs.

Have you tried other gtk themes (system :smile: )?

1 Like

Yes I have. Unfortunately it doesn’t fix the bug.

1 Like

I remember some random stuff like that from Manjaro days, looks more like some kind of video driver / mesa issue with AMD GPU…

@Kovariszt are you sure it’s GTK only?


We can’t do any credible guess/assessment without any system info.
Use EnOS tools to upload relevant info in a pastebin service.

I can’t find this file in package DBs. Can you check the owner packege, please?


Mai 02 20:19:44 endeavour kglobalaccel5[35575]: Fontconfig warning: “/etc/fonts/conf.d/69-language-selector-ja-jp.conf”, line 172: Having multiple values in isn’t supported and may not work as expected

1 Like

Yeah, I also think it’s a driver thing. I am absolutely sure it’s a GTK thing because I use KDE and none of my qt stuff is behaving like that and the lucid toolkit version of Emacs also doesn’t have the issues described. It only ever occurs in GTK programs.

Is this the system info you mean?
The fontconfig thing is just there because I configured my Japanese fonts weirdly (the default fonts looked bad and now I have good fonts so I’m scared to change anything), you can safely ignore that. I’ve had this bug since long before I even set up my fonts like that.

  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: XFX Pine driver: amdgpu v: kernel pcie: speed: 16 GT/s lanes: 16
    ports: active: DP-1,HDMI-A-1 empty: DP-2,DP-3 bus-ID: 0c:00.0
    chip-ID: 1002:731f

Already there since 2020 so not one of the latest.
And listed as working mostly:

DMI: To Be Filled By O.E.M. To Be Filled By O.E.M./B450 Steel Legend, BIOS P3.40 06/04/2020
could be newer Bios is there :wink:

Mai 02 14:40:27 endeavour kernel: amdgpu 0000:0c:00.0: amdgpu: RAP: optional rap ta ucode is not available
is mostly the only error i find in the log…

What does that error mean? How would I go about updating my Bios?

i have no clue about the error … but it is a starting point to do research…

But you could check two things first:

  1. using LTS kernel.
  2. try to start wayland session., to see if it is the same (if not it could be some settings for xorg needed)

Bios updates are different from device to device and manufacturers… you can check the downloads available on the motherboard website. And … your manual :wink: could be you can update out of the Bios or need a Windows instance to apply…

Moved this post to the Plasma category.

1 Like

These green pixels look like a bug that I have reported to the xorg devs 5 month ago. It only happens on AMD RDNA/RDNA2 cards, like my Radeon RX 5600 XT GPU. The bug is confirmed and will be fixed with the next major release - hopefuly.

Solution is to dowgrade several xorg packages.

For me the bug is most visible with darktable. Thats why I initially raised it to the darktable devs:


also it seems to be plasma (QT) and issue is only in gtk apps?
Could help to check gtk theme settings.

1 Like

Thank you so much. So if I just keep on updating my system it’ll be fixed eventually? How do I downgrade those xorg packages?

I have also had these issues when I was briefly using XFCE, so I don’t think it’s a Plasma issue

The packages to downgrade are listed in the xorg bug report. As well the location where to find them. Download them to a dedicated folder, cd into that folder and do sudo pacman -U *

If that fixes your issue you should add the packages to the ignore list in pacman.conf.

I have done several upgrades / downgrades in the past to check if new xorg versions still have the bug. I had no issue with any downgrade/upgrade. From my point of view it is save for you to try it out.

1 Like

Plus Xorg log (while your issue was present) and xrandr.
I don’t expect much to find, as this seems too in-depth video driver complication and my guru cousin is on vacation at Thibet these days… :laughing:

Thank you so much. This has finally fixed this issue for me. Do you have any idea how I could be notified when the issue gets resolved and I can update those packages?