GRUB working but not displaying on screen

Hi there. I recently installed Endeavour OS on my main computer in a dual boot with Windows. At the beginning everything worked perfectly, both OS’s showed correctly. But recently when I turn on my PC, it shows “no signal” from my monitor, and then proceeds to show Endeavour correctly.
To clarify, GRUB is there and it is working well, it’s just that I can’t see it (if I press the down arrow when there is no signal, as if I were to change OS, I can log into Windows)
I didn’t touch anything GRUB related in this system, so I have no idea of what could be the reason for this happening.
Does anyone know what is happening or if there is a way to “reinstall” GRUB so I can see it again?

Check this wiki page:

1 Like


i have exact the same problem (dual boot too).

BUT, it happens only if i boot Windows, and then i restart from Windows. The next reboot would be “black screen” but grub is working. For me no problem, and didnt searched a solution for that, because i know the first entry is endeavour, the secound one windows. This problem didnt occur, if i shutdown Windows. And if i push again the power button, everything is ok.

So i try now your tip! :slight_smile:

That sounds like a different issue, and possibly due to something like Window’s fast resume “feature” (where it goes into a hybrid suspend rather than powering off).

Yeah that was my first idea years ago. But that didnt was the problem (because its disabled anyway).

Tried now your tip. But i found out that the default settings are already like in the wiki. So no need to change.

I think that is a specific problem with my System and the hardwarecombination (because i didnt see the BIOS splash too if i reboot like described).

The main problem can be solved easily. Just remove Windows … there are no more GRUB issues. :rofl:


What GPU and driver used would be interesting:
inxi -Ga
And what @jonathon linked to includes also that you can set the display resolution for grub, so if you have a 1920x1080 you can try set this for grub like so:
sudo nano /etc/default/grub
edit the line:
if you want to go sure that this resolution is supported follow the commented hint in the file that says:

The resolution used on graphical terminal
note that you can use only modes which your graphic card supports via VBE
you can see them in real GRUB with the command `vbeinfo’

where the command has changed and is now videoinfo what you can run from inside grub. after pressing “c” for commandline in grub.

I would mark your reply as the solution, if I were the OP.


indeed it is a solution :rofl: