Grub screen after remove/replace nvme

Hi,

I had to remove the NVME holding EOS (KDE) whilst working on the mother board. When I placed it back rather than booting as normal I am presented with the blank Grub screen rather than the boot options ( I have Win on a separate drive). Everything was working fine prior to the removal. When i look into the BIOS for boot sequence it seems to shows Ubuntu rather than EOS.

Any hints would be welcome as I dont look forward to trying to rebuild everything again.

My first instinct is to re-check your connections / cables, both data and power where applicable. In terms of NVME, re-seat it.

yes I tried reseating but its the same.

If I run “ls” at the Grub prompt I believe I can see all the disks ie hd4,gpt1 etc. Not sure if I can find my way to the boot through this.

but I have run: root=(hd4,gpt1) linux + TAB gives /efi/endeavouros/grubx64.efi. if pres return at this point i get “invalid magic number”. so not sure what to try next, if this is even a correct method

Chroot in and rebuild your initramfs, sudo reinstall-kernels.