Grub rescue on startup

I was dual booting manjaro&windows at first and then decided to use endeavourOS as a daily driver(its my favorite distro i’ve yet to try). I wanted to allocate more disc space to endeavourOS so i went on my windows partition and removed the manjaro partition and now i get to see the grub rescue menu at boot everytime. I have used a tutorial to get out of the menu and log on endeavourOS but i dont want to go trough the steps everytime i boot. Is there a permanent fix?

This is what i have to do each time i boot:

set boot=(gpt,hd4)
set prefix=(gpt,hd4)/boot/grub
insmod normal
normal

due to me not being comfortable with the american keyboard(i normally use azerty) this takes a minute or two. It may seem nitpicking but it kinda bothers me.
If anyone knows how to fix it please tell me.

Go into your BIOS and and ensure you are booting the correct entry by default. You are probably trying to boot Manjaro’s grub(which no longer exists) so you get that error.

Have you turned off fast boot in the Windows settings?

Did you update grub on EOS after removing the Manjaro partition?

Thanks for responding, Yes i just updated grub now and it stil gives me the menu. I will try the fix the first reply gave now.

How do i change the bios settings to do that, i checked my “boot menu” and it has endeavourOS on the top so ithink thats correct

i am using a hp pavillion 15-eh something laptop

Can you post your lsblk -f ?


(this is in the terminal after booting, if i needed to do it in the grub commandline please tell me)

What does the command efibootmgr show?

From within EnOS, you could try a grub-install to nvme0n1. Then update grub and see if the problem persists.

Timeout: 0 seconds
BootOrder: 0005,0000,0001,0002,0006,9999
Boot0000* Manjaro       HD(1,GPT,180f50a5-a098-4837-9e92-6a8df94a89b0,0x800,0x82000)/File(\EFI\Manjaro\grubx64.efi)
Boot0001* Windows Boot Manager  HD(1,GPT,180f50a5-a098-4837-9e92-6a8df94a89b0,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000026000100000010000000040000007fff0400
Boot0002* Internal Hard Disk    PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/NVMe(0x1,00-00-00-00-00-00-00-00)/HD(1,GPT,180f50a5-a098-4837-9e92-6a8df94a89b0,0x800,0x82000)0000424f
Boot0005* endeavouros   HD(1,GPT,180f50a5-a098-4837-9e92-6a8df94a89b0,0x800,0x82000)/File(\EFI\endeavouros\grubx64.efi)
Boot0006* Internal Hard Disk    PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/NVMe(0x1,00-00-00-00-00-00-00-00)/HD(6,GPT,ce7c31ec-77af-c448-b7c6-a68a2f297be2,0x3b4c2800,0x1f4000)0000424f
Boot9999* USB Drive (UEFI)      PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)0000424f

This is the output of efibootmgr

I will try the second thing you mentioned if you dont see a way to use the first thing to fix it.

First thing, delete the Manjaro entry. See efibootmgr commands on Arch Wiki, then update grub, then reboot.

(post deleted by author)

I deleted the manjaro entry and updated grub using
sudo grub-mkconfig -o /boot/grub/grub.cfg
and then i rebooted but it still gave the grub rescue thing at start, i then went in to the boot menu of the bios and didnt have manjaro anymore so it think the first step worked maybe i need to update grub another way

So another grub-install to the main drive and subsequent grub-update seem to be needed. Reboot after that.

It worked!, Thank you so much for responding quickly you are a life-saver.
Man i changed to endeavourOS because people told me the community was really helpful, and it did not disappoint.

1 Like

Glad, you got it working! It would be nice of you, to mark the corresponding post in this thread as “Solution”. :v:

Thanks! :smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.