Grub error at the end of the installation

I got a grub error at the end of the installtion, how can i fix the error?

I used gparted too setup my partitions like this:
/dev/sda1 efi fat32
/dev/sda2 / ext4
/dev/sda3 swap

Welcome,
Did you set /boot/efi on efi partition?

Thanks👍

Yes i did that!

There is EFi at the top left on the installer also and i’m not sure if you have you have to select that? I haven’t used the installer on an EFI system yet. Mine is already moved over from Antergos to Endeavour. Did you happen to notice? I know there is an upstream issue with the Calmeres installer that sometimes it has an issue. You also know to have secure boot off. Check out the page here: https://endeavouros.com/docs/system-rescue/repair-grub-efi-uefi-system/

1 Like

The installer says EFI at the top left, and i have secure boot disabled. I had another distro on the laptop. So it should work without a problem

What is the hardware , Brand / model / ssd/hdd such stuf.

how much distro did you had on the laptop. some how could not register the boot entry…

1 Like

I had arch,fedora,debian on it before with out any problems👍 The machine is a asus x200MA intel n2830 4gb ram 120gb crucial bx500

I understand what you are saying but for whatever reason it hasn’t this time. Are you installing Endeavour on its own? Have you given it another try? Don’t give up too easily. It happens now and again. Been there, done that! How did you create the ISO? Hope you try it again.

Yes Eos wil be the only OS on the computer if i can get it installed. i have redownloaded the iso and tried to burn it to the usb with DD this time instead of Etcher.same error.

Thanks everyone so far for helping me out👍

Tomorrow the new ISO (with bugfixes) will be available and maybe you could try to burn it with Imagemaker?

@Bryanpwo Is there a time that the ISO will be released? What time zone?

The ISO still needs some minor tweaking, but the aim will be around 15:00 CET.

1 Like

Awesome i will defintly try that iso out now that it includes bugfixes👍

yeah just wanted to know. dont know even if there is issues with the old efi is difficult to tel, got my self a asus board efi did fine here. i think mean while is it possible to check also your efi-bios is up2date? grub needs the efibootmgr but somehow it could not point out the entry to install it basicly , it fall of some variable…

im not a efi specialist also :slight_smile:

I have updated my Uefi Bios numerous times since it was released. Asus TuF Z370 Pro Gaming

Hehe no worrys :slightly_smiling_face: when i installed Arch the arch way i got grub and efi to play nicely with out hickups on this laptop and there are no bios updates the machine is pretty old these days. But maybe my machine is a bit cranky then others, but i will try the new iso when it’s out and report back here the result!

As a matter of interest, my two Linux computers (Intel NUC5 & Asrock deskmini Ryzen 2200G) are uefi. I don’t use Grub when I install the Arch way. I use ‘bootctl’ and it works just fine. On endeavouros, there is no choice, of course, but it still works fine. I don’t particularly like GParted and I prefer cfdisk. However, in either case, by deleting any old partitions on the SSD and then simply creating one ext4 linux partition (making sure that the partition is GPT), the endeavouros installer creates the efi boot partition and a root partition without any difficulty.

1 Like

@davidw I have not used bootctl but i will look at the info on it. I also use and like cfdisk when installing Arch. It’s very easy and understandable and it works good. There are so many different tools that can be used for partitioning. So if i understand you correctly you are saying that on Endeavour you are using gparted and you create just a GPT partition first of the whole drive. That’s what i would do also but if I am installing Arch and the partition scheme is correct i just go right to mkfs.ext4 etc and just reinstall on the existing setup. I think what you are doing is a perfectly correct way of proceeding to do the install.

Been trying to install the latest iso image yet the same problem presist.

This are the partition. Tried doing without swap partition and also with root partition and efi boot and yet after installation it boots into bios instead of the os.
Currently using an Optimus laptop.
Specs:
I7 7700HQ
256GB nvme
16Gb ram
Nvidia 1050ti
Intel hd graphics.