GRUB config does not contain any entries

For whatever reason, this OS will not complete the install on my laptop, and the failure step is always Grub. Since Grub is the last step though I can install Grub manually via chroot. The issue is grub-mkconfig never actually generates a valid Grub config, it seems to be totally ignoring everything in /etc/grub.d, here’s the output of grub-mkconfig -o /boot/grub/grub.cfg on my main PC:

Generating grub configuration file ...
Found theme: /boot/grub/themes/Vimix/theme.txt
Found linux image: /boot/vmlinuz-linux-tkg-pds-haswell
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-pds-haswell.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-pds-haswell-fallback.img
done

Yet when I chroot or even boot manually and run grub-mkconfig -o /boot/grub/grub.cfg on this failed install, all I get is this:

Generating grub configuration file ...

and there are no menu entries in the file, plus it doesn’t even generate the file I tell it to, it generates it as grub.cfg.new. It will boot if I create the menu entries myself, but anything that leads to the creation of a new grub file will of course break everything again. I could drop a custom entry in a file in /etc/grub.d, but oh wait it’s totally ignoring the files that exist there already.

you should also check under terminal
and just before installing

test -d /sys/firmware/efi && echo efi || echo bios
inxi -Mxxxa

/boot/grub/grub.cfg on my computer is blank.

Also, are you dual booting different distros? The Vimix theme is not present in the installation of Endeavourt, afaik?

Edit: I know the bootloader has been an issue in the past when using the partitioner built into calamares. My advice is to manually partition the disc(s) in gparted first, then run the installer and map /boot/efi to the fat32 partition you create manually.

The first command echos efi. The second one displays device info which this is an Asus Vivobook F512DA.

It sounds like it’s failing between generating the config file and copying into place.

Have you checked file permissions, disk space, … ?

Have you tried running grub-mkconfig by itself to see if it’s generating any output?

The first output is from my main PC to demonstrate about what I expect to see, of course Vimix theme excluded. The second output is from the laptop in question which doesn’t mention anything about EndeavourOS’s theme, nor any kernel images. This is a single-boot device I am actually switching distros the drive is clean.

Also I did manually partition my disk because I formatted my root partition as f2fs with encryption enabled which afaik is not a default option.

1 Like

grub-mkconfig by itself does generate output, but it’s lacking any menu entries thus resulting in a broke Grub install. As for permissions and/or disk space, if that’s an issue how would be be writing grub.cfg.new to the directory? I am running grub-mkconfig as superuser anyway and I’d have no reason to set an immutable flag on anything so superuser should be able to write the requested file.

Can you take a screenshot of the partition setup in Calamares with your mapping as you did intend it to be before having to do it manually? I mean you sound like you know what you’re doing, but this smells like an EFI partition problem.

Two questions follow:

  1. Do you have a kernel installed, and
  2. What have you changed in /etc/default/grub and/or under /etc/grub.d/ ?

Are you sure that it is writing a new copy and you’re not looking at an old one? Diagnostic questions are there to prompt, not to solve.

1 Like
  1. Yeah this is literally fresh from the installer so I would hope the installer is bothering to install the kernel (which it is the images are in /boot). Afaik Grub is the last step that Calamares takes before the install is finished so everything else should be complete
  2. Nothing.

Are you sure that it is writing a new copy and you’re not looking at an old one? Diagnostic questions are there to prompt, not to solve.

I am sure, because there is no original copy (grub.cfg doesn’t exist because the installer fails at generating it)

1 Like

I am experimenting around and I imaged an install from another device, but this is roughly the partition layout I am attempting (larger rootfs is about the only difference)

Are you sure you have all tools for f2fs installed? I have seen a few posts searching about this where Arch users (manual installation or not) have exactly this issue.

I think @freebird54 might have the answer to this here as he just went through this with f2fs. I think he also said you need the /boot partition. But something else?

Are you sure you have all tools for f2fs installed? I have seen a few posts searching about this where Arch users (manual installation or not) have exactly this issue.

Yeah it’s in the latest EndeavourOS live iso actually. I think even the vanilla Arch ISO has it included now.

Also according to the almighty Internet Grub2 added support for f2fs for /boot 2018, it seems a separate Ext4 boot is not neccesary?

I initially tried that but then set up a separate boot partition as a troubleshooting step. The PC I imaged from (that’s the partition layout you’re seeing) is a pre-2018 install so that’s why it’s separate.

1 Like

I stand corrected, then.

Don’t quote me on that but I’m pretty sure i was discussing it with him. I just can’t remmember exactly. :upside_down_face:

1 Like

I am sure you’ve followed this?

https://www.linuxsecrets.com/archlinux-wiki/wiki.archlinux.org/index.php/F2FS.html

Yes.

1 Like

This is the part that worries me;

Warning: If using F2FS as your root partition, you will need to add the following module to the MODULES line in your /etc/mkinitcpio.conf file (FS#49380):

crypto-crc32

I don’t know if that’s actually relevant today though I think that module is loaded automatically since a good while. Even when it was I’ve known installers to add that line automatically.