Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

AME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS
loop0
squash 4.0 0 100% /run/archiso/airootfs
sda
├─sda1
│ ntfs Recovery 9288782988780DCB
├─sda2
│ vfat FAT32 EE79-27A5
├─sda3

├─sda4
│ ntfs 16B87ABEB87A9BC5
└─sda5
ntfs A2B2574CB2572457
sdb
├─sdb1
│ vfat FAT32 NO_LABEL F742-07D4
└─sdb2
ext4 1.0 8ba6df0b-46ba-4d27-af84-8a1e5ed5c4d5
sdc
├─sdc1

└─sdc2
ntfs Disk2 8E5C735A5C733BD1
sdd
└─sdd1
vfat FAT32 EOS_202208
0A8D-87F6 13.1G 11% /run/archiso/bootmnt

@Yackasone

Just as an explanation. When you want to chroot you need to first mount the partition that your system is installed which is the root partition. Then you have to mount the efi partition which is your boot partition then you need to arch-chroot. Hopefully this makes more sense to you.

1 Like

if all mounted properly then sudo arch-chroot /mnt

do you wanna have little fun : sudo systemd-nspawn -b -D /mnt

but going out that container i dont know my keys are sketchy :slight_smile:

Thank you for this explanation. The guide had me a bit confused but you’ve cleared it up. I’m now back on my regular installation, and I’m so grateful for the help I got from this thread. I’m still new to linux as you can probably tell and without your help I would probably be dead in the water.

1 Like

Hey
So i recently made the switch to linux from windows so im still new to this.

Today i updated my system and restarted my pc when i came back it had booted to Windows(as i had not uninstalled it yet) and i think that might have broken something because when i tried to boot Endeavour again it just fails. It tries to boot but then the screen goes black and it opens bios.

Would give a video but not sure how to include it here.

Hope someone can help me with this.

this is exactly the issue discussed here or not?
the solution is here:

Hello,

To recover my system, I would like to follow the instructions >>>

https://discovery.endeavouros.com/system-rescue/arch-chroot-for-efi-uefi-systems/2021/03/

But I don’t understand them.
My partition is encrypted and I don’t know which commands apply to me.

Here is info:
Screenshot_2022-08-28_23-34-58

Screenshot_2022-08-28_23-36-10

Just what are the commands specific to my case

Could you please help me ?
Thanks in advance.

pls check arcolinux they kept grub on hold for 5 years
EnOs can this as well?

EOS doesn’t have an overlay repo so we cannot hold packages coming from arch.

1 Like

According to the video all of Arco’s repos are before Arch repos

1 Like

oki then in the installer offline torn off pcaman pkg grub?

Your efi partition is /dev/sda1

Your Linux root partition is probably /dev/sda4

If it is ext4, it would be something like this:

First you would unlock the partition then do the rest as normal

sudo cryptsetup open /dev/sda4 myluks
sudo mount /dev/mapper/myluks /mnt
sudo mount /dev/sda1 /mnt/boot/efi
sudo arch-chroot /mnt
grub-install
exit
reboot

Unfortunately, that isn’t understandable for me.

install EOS offline just off in /etc/pacman.conf
IgnorePkg = grub
thing about new user get fu…ck after update

That would just put every system in a permanent partial update status that would require manual intervention to correct.

It is more likely we would do the opposite which to update the version of grub on the ISO to the latest.

It is more likely we would do the opposite which to update the version of grub on the ISO to the latest.

This seem to be a better way to fixing it. Nova incoming ? :open_mouth:

3 Likes

if You linux user can fix but if you new switcher and after update only bios they probably newer come back

Hi, having trouble arch-chrooting into my home directory in a LUKS encrypted vlume, the error I get is just that the directory /bin/bash can’t be found.
I mount the LUKS system as described
sudo cryptsetup open /dev/nvme0n1p2 mycryptdevice
sudo mount /dev/mapper/mycryptdevice /mnt
sudo mount /dev/nvme0n1p1 /mnt/efi
sudo arch-chroot /mnt
I then get the error message
“chroot: failed to run command ‘/bin/bash’: No such file or directory”
/bin/bash can be found at /mnt/@/bin/bash and I’ve tried copying it to /mnt/bin/bash and even /bin/bash but still the same error.
I’ve found running sudo arch-chroot /mnt/@ “works”, but I get the following error message as well
==> WARNING: /mnt/@ is not a mountpoint. This may have undesirable side effects.
Running grub-install then gives the error message:
grub-install: error: cannot find EFI directory.
Any help on what I’m doing wrong please? :sweat_smile:

It because you are using btrfs. @lugh wrote instructions for this above. Here is a link:

Thank you very much and to Lugh, I didn’t even realise I was using btrfs, I suppose that’s what the “@” signifies >.>.
Working now :slight_smile:

2 Likes