Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

I successfully arch-chrooted to resolve this on both my Arch desktop and EndeavourOS laptop, but can’t get the Grub splash to show on my EOS install even though it successfully shows on my Arch install. I’m happy that I can boot, but I’d like to be able to select my LTS kernel if necessary in the future. Any help would be greatly appreciated. Thanks!

see if you have to change the boot order for EFI.
Instructions are in the pinned post.

Thanks for the quick response! I’m familiar with using efibootmgr, but not sure what you’d suggest I change it to

BootCurrent: 0013
Timeout: 0 seconds
BootOrder: 0013,0000,0001,0002,0003,0009,0007,0008,000A,000B,000C,000D,0012
Boot0000  Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0001  Boot Menu     FvFile(126a762d-5758-4fca-8531-201a7f57f850)
Boot0002  Diagnostic Splash Screen      FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0003  Lenovo Diagnostics    FvFile(3f7e615b-0d45-4f80-88dc-26b234958560)
Boot0004  Startup Interrupt Menu        FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
Boot0005  Rescue and Recovery   FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
Boot0006  MEBx Hot Key  FvFile(ac6fd56a-3d41-4efd-a1b9-870293811a28)
Boot0007* USB CD        VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0008* USB FDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0009* ATA HDD0      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot000A* ATA HDD1      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
Boot000B* ATA HDD2      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot000C* USB HDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot000D* PCI LAN       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot000E* IDER BOOT CDROM       PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,1,0)
Boot000F* IDER BOOT Floppy      PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,0,0)
Boot0010* ATA HDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
Boot0011* ATAPI CD      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
Boot0012* PCI LAN       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot0013* EndeavourOS-grub      HD(1,GPT,0203bb2f-2c86-4f75-91ae-d8f2714973d9,0x800,0x100000)/File(\EFI\EndeavourOS-grub\grubx64.efi)

Yes, this fine. Run grub-mkconfig to see if it fixes the issue

I just updated and after i restarted my pc it wouldn’t let me go into the linux boot just the system menu. This is an emergency for me because my lapyop has some important logins for applying for jobs and stuff like that.

I having a panic attack over it. Please help!

Thank you. I was not made aware of of this issue before hand. I will try to do this tomorrow.

2 Likes

Still no splash screen, unfortunately. My /etc/default/grub is unchanged, so I’m at a loss.

I’ve had a lot of problems with grub also. I wiped my system a number of times. Fresh installs weren’t any better. Having it boot wasn’t the problem. Having it not do the same again if updating grub was a problem. Now it seems to be okay and i have no idea what i did but Ive updated grub a number of times and it’s been working now. I installed other kernels and it’s booting without issue so far. If it comes back with updating i don’t know. :man_shrugging:

Even stranger, the splash screen will occasionally show after I enter the bios menu–but not always. Curiouser and curiouser… :thinking:

I’ve had it boot to UEFI screen, or boot to grub rescue or boot to out of memory error. I even reinstalled numerous times. Finally now it seems more stable. Not sure why. :man_shrugging:

It looks like you need to mount the root partition before EFI :

  1. Find the device names of the root partition and the EFI (boot) partition of your installed system with fdisk:

fdisk -l

  1. Mount the Root partition (where you replace sdXn `` with the actual partitions):

	Syntax: mount /dev/sdXn /mnt

	
sudo mount /dev/sda5 /mnt

  1. Mount the EFI partition (where you replace sdYn with the actual partitions):
	Syntax: mount /dev/sdYn /mnt/boot/efi

	
sudo mount /dev/sda1 /mnt/boot/efi
1 Like

I tried rEFInd a long time ago and it was OK.
But currently - after a fresh install - I converted to systemd-boot by following instructions of @dalto in another thread.

I chose systemd-boot because it is simpler than Grub and rEFInd, easier to maintain and fix, less prone to problems because of its simplicity.

It is worth trying despite it does not support booting to earlier snapshots. But I feel better and safer with systemd-boot.

It is faster to boot as well.

1 Like

Why does this Grub issue only occur on UEFI systems? How do you know fwsetup is invoked? I have an old problem that I described here, UEFI Grub and BIOS Grub in parallel i.e. I can only start EndeavorOS Grub after switching to legacy only mode in the BIOS. Could this problem after the Grub update affect me?

Is this issue fixed? Can I update my OS today without breaking grub again?

My mirrors aren’t showing an updated grub, so…no it’s not fixed (unless I’m out of date).
I’m quite disappointed in how long this has remained an issue upstream.

Great place to look…

https://archlinux.org/packages/?sort=-last_update

1 Like

I got to step 8. then terminal prints this error

[root@EndeavourOS /]# sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub
Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn't look like an EFI partition.

Does anyone know whats the issue here?

Disk /dev/sda: 256.17 GiB, 275064201216 bytes, 537234768 sectors
Disk model: Crucial_CT275MX3
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6C90BC5C-7D01-5148-9B0A-52DAD03757DA

Device         Start       End   Sectors  Size Type
/dev/sda1       2048    616447    614400  300M EFI System
/dev/sda2     616448 107149311 106532864 50.8G Microsoft basic data
/dev/sda3  107149312 189069311  81920000 39.1G Linux filesystem
/dev/sda4  189069312 537233407 348164096  166G Microsoft basic data


Disk /dev/sdb: 14.32 GiB, 15376000000 bytes, 30031250 sectors
Disk model: Ultra USB 3.0   
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x002a9742

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdb1  *     2048 30031249 30029202 14.3G  c W95 FAT32 (LBA)```

You probably mounted the wrong partition in /boot/efi

Reboot on the Live USB (to clear any mount actions).

Try:

sudo mount /dev/sda3 /mnt
sudo mount /dev/sda1 /mnt/boot/efi

then sudo arch-chroot /mnt

3 Likes