Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

Hey all,

I tried the published solution but still i could not solve problem. interestingly my windows 11’s wifi specification disappeared suddenly, it is also can not read mounted devices and it shows error on setting page. actually i do not know these two problem are related or not, but for now i have a trouble with my device because i could not use it.

let me go step by step;

i have 3 os on my device; windows 11, endeavour os and ubuntu.
and i have endeavour os live on my usb flash drive.

$ sudo fdisk -l

Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: INTEL                    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6F9C63F3-CC2B-455F-AF20-4D14346BD334

Device             Start       End   Sectors   Size Type
/dev/nvme0n1p1      2048    206847    204800   100M EFI System
/dev/nvme0n1p2    206848    239615     32768    16M Microsoft reserved
/dev/nvme0n1p3    239616 305981439 305741824 145.8G Microsoft basic data
/dev/nvme0n1p4 305981440 307197951   1216512   594M Windows recovery environment
/dev/nvme0n1p5 307197952 409597951 102400000  48.8G Linux filesystem
/dev/nvme0n1p6 409597952 614397951 204800000  97.7G Linux filesystem


Disk /dev/sda: 7.27 GiB, 7801405440 bytes, 15237120 sectors
Disk model: Flash Disk      
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x593e4509

Device     Boot   Start     End Sectors  Size Id Type
/dev/sda1  *         64 3564735 3564672  1.7G  0 Empty
/dev/sda2       3564736 3777727  212992  104M ef EFI (FAT-12/16/32)


Disk /dev/loop0: 1.6 GiB, 1714974720 bytes, 3349560 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

actually i do not know which linux filesystem partition is eos or ubuntu. (nvme0n1p5 or nvme0n1p6)
i tried tutorial’s commands both of them.

when i tried these commands,
sudo mount /dev/sdXn /mnt
sudo mount /dev/sdXn /mnt/boot/efi
with nvme0n1p5 it is work, but nvme0n1p6 show error with second line command. it says:

$ sudo mount /dev/nvme0n1p6 /mnt/boot/efi

mount: /mnt/boot/efi: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.

i thought nvme0n1p5 is eos.
when i try to sudo btrfs subvolume list -p /mnt it says:

$ sudo btrfs subvolume list -p /mnt

ERROR: not a btrfs filesystem: /mnt
ERROR: can’t access ‘/mnt’

also my disk is not encrypted:

$ lsblk -f

NAME        FSTYPE  FSVER     LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0       squashf 4.0                                                              0   100% /run/archiso/airootfs
sda         iso9660 Joliet Ex EOS_202208  2022-08-05-07-19-08-00                     0   100% /run/archiso/bootmnt
├─sda1      iso9660 Joliet Ex EOS_202208  2022-08-05-07-19-08-00                              
└─sda2      vfat    FAT16     ARCHISO_EFI 826B-8B64                                           
nvme0n1                                                                                       
├─nvme0n1p1 vfat    FAT32                 88F1-99DF                                           
├─nvme0n1p2                                                                                   
├─nvme0n1p3 ntfs                          2210C99010C96B7D                                    
├─nvme0n1p4 ntfs                          66DC2B55DC2B1F35                                    
├─nvme0n1p5 ext4    1.0                   65adf1d3-f6c8-4972-a58d-51d98e5b6117                
└─nvme0n1p6 ext4    1.0                   70b4f792-330c-4d00-81d7-8718fb00ec4e 

when i try to chroot with nvme0n1p5, i saw i could not accessed my eos because it does not show me my files on home folder:

$ sudo mount /dev/nvme0n1p5 /mnt
$ sudo mount /dev/nvme0n1p5 /mnt/boot/efi
$ sudo arch-chroot /mnt

# ls /home
#

it is obvious, something goes wrong but i just keep follow instructions on tutorial…

# sudo efibootmgr

BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0003,0004,0000,0001
Boot0000* Windows Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000064000100000010000000040000007fff0400
Boot0001* EndeavourOS	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0002* rEFInd Boot Manager	HD(1,GPT,7194dd2b-b108-45a1-ad45-fb1a2d20517c,0x800,0x32000)/File(\EFI\refind\refind_x64.efi)
Boot0003* UEFI: Generic Flash Disk 8.07	PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(0,0)/CDROM(1,0x3664c0,0x34298)0000424f
Boot0004* UEFI: Generic Flash Disk 8.07, Partition 2	PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(0,0)/HD(2,MBR,0x593e4509,0x3664c0,0x34000)0000424f

(also i installed rEFInd, after i could not fix GRUB.)*

and finally i follow EFI/UEFI guide for last step.

# grub-mkconfig -o /boot/grub/grub.cfg

Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
done
# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn't look like an EFI partition.

I researched my problem on endeavouros forum, arch forum, google, youtube, stackoverflow etc., i tried many things but could not fix it.

Is there anyone know that what is my problem? Thanks for help beforely…

*rEFInd has just endeavouros live which installed on my usb stick on its list. is it possible to add other os’es to the list?

It is because you mounted your root partition twice. You mounted it at /mnt and /mnt/boot/efi

You need to mount your efi partition, the first one at /mnt/boot/efi

3 Likes

So is that refind-btrfs you are using?
Sounds like an interesting test to do.

1 Like

I also have InsydeH20 and could not see how to add the grub entry.
One thing I did notice is, if you are not using a password, you will only have basic options available. As soon as you add a password, it will go into an advanced mode.

Hi, I’m another unfortunate victim of the grub update error… When I run grub-mkconfig -o /boot/grub/grub.cfg, it says /boot/grub/grub.cfg directory/file not found. The same thing happens when I run downgrade grub.

My system runs on UEFI if that helps.

have you followed the instructions on the pinned post carefully? you must’ve mounted the wrong partitions somewhere?
Reboot the ISO, redo the steps and carefully read the terminal outputs for errors.

I mounted both my sda1 and sda2 partitions.
here’s what I did specifically:
sudo mount /dev/sda2 /mnt
and
sudo mount /dev/sda1 /mnt/boot/efi

I mounted my sda2 partition first, which is my linux filesystem, then my sda1 partition, which is EFI.

Did I do it in the wrong order? or does it even matter?

The order does matter. You need to mount the efi partition after the root partition.

Are you running those commands from with an arch-chroot?

I ran arch-chroot after I mounted my partitions.

I would reboot. Then do it again. This time share all the commands and the output from the terminal here so we can see what went wrong.

Okay so I tried it again and I managed to get my system working again. I must’ve made a spelling error when I mounted my partitions.

2 Likes

I successfully arch-chrooted to resolve this on both my Arch desktop and EndeavourOS laptop, but can’t get the Grub splash to show on my EOS install even though it successfully shows on my Arch install. I’m happy that I can boot, but I’d like to be able to select my LTS kernel if necessary in the future. Any help would be greatly appreciated. Thanks!

see if you have to change the boot order for EFI.
Instructions are in the pinned post.

Thanks for the quick response! I’m familiar with using efibootmgr, but not sure what you’d suggest I change it to

BootCurrent: 0013
Timeout: 0 seconds
BootOrder: 0013,0000,0001,0002,0003,0009,0007,0008,000A,000B,000C,000D,0012
Boot0000  Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0001  Boot Menu     FvFile(126a762d-5758-4fca-8531-201a7f57f850)
Boot0002  Diagnostic Splash Screen      FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0003  Lenovo Diagnostics    FvFile(3f7e615b-0d45-4f80-88dc-26b234958560)
Boot0004  Startup Interrupt Menu        FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
Boot0005  Rescue and Recovery   FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
Boot0006  MEBx Hot Key  FvFile(ac6fd56a-3d41-4efd-a1b9-870293811a28)
Boot0007* USB CD        VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0008* USB FDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0009* ATA HDD0      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot000A* ATA HDD1      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
Boot000B* ATA HDD2      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot000C* USB HDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot000D* PCI LAN       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot000E* IDER BOOT CDROM       PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,1,0)
Boot000F* IDER BOOT Floppy      PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,0,0)
Boot0010* ATA HDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
Boot0011* ATAPI CD      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
Boot0012* PCI LAN       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot0013* EndeavourOS-grub      HD(1,GPT,0203bb2f-2c86-4f75-91ae-d8f2714973d9,0x800,0x100000)/File(\EFI\EndeavourOS-grub\grubx64.efi)

Yes, this fine. Run grub-mkconfig to see if it fixes the issue

I just updated and after i restarted my pc it wouldn’t let me go into the linux boot just the system menu. This is an emergency for me because my lapyop has some important logins for applying for jobs and stuff like that.

I having a panic attack over it. Please help!

Thank you. I was not made aware of of this issue before hand. I will try to do this tomorrow.

2 Likes

Still no splash screen, unfortunately. My /etc/default/grub is unchanged, so I’m at a loss.

I’ve had a lot of problems with grub also. I wiped my system a number of times. Fresh installs weren’t any better. Having it boot wasn’t the problem. Having it not do the same again if updating grub was a problem. Now it seems to be okay and i have no idea what i did but Ive updated grub a number of times and it’s been working now. I installed other kernels and it’s booting without issue so far. If it comes back with updating i don’t know. :man_shrugging: