Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

I just want to understand if there is/was something I should have read, but in the solution it says:

2. Rebuild the grub.cfg configuration file

grub-mkconfig -o /boot/grub/grub.cfg

Now reinstall GRUB:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

Now GRUB is repaired and you should be able to boot into your system again.

That is what I did. I cannot seem to find any indication that I have to change some default afterwards. Where do I do that?

I most cases you don’t. However, some people have reported needing to. When you get into things that touch the firmware settings, hardware differences come into play.

The easiest way is to go into your bios and simply change the default in the boot order settings.

However, you can also change the order using efibootmrg

2 Likes

After I updated my GRUB I couldn’t load into my OS, so I went on forums for help and I saw this post: https://discovery.endeavouros.com/system-rescue/arch-chroot-for-efi-uefi-systems/2021/03/

It says that I need to run sudo mount /dev/sdXn /mnt, however when I run it, I get the error like this:
image

Basically I have no idea what the article is trying to say, I’m really new to this linux stuff.

Here are my logs just in case: https://clbin.com/R7u88

Boot log: https://clbin.com/H2Lds

Also here’s my sudo fdisk -l:
image

Any help would be greatly appreciated!

That’s the burning question my friend. I asked that same question.
Maybe @joekamprad might add some more details to point 2. https://discovery.endeavouros.com/video-tutorials/fix-arch-linux-boot-with-arch-chroot/2021/12/

The instructions meant that first you have to mount your installed linux partition to /mnt/ and then mount your EFI boot partition to /mnt/boot/efi/

In your case, it would be great if you can find out which of your linux file system is the root partition. If you remember it right, then great or else we can hit and trial.

sudo mount /dev/sda6 /mnt

Check in your file manager that /mnt/ is your installed linux root partition. If it’s not, then

sudo umount /dev/sda6
sudo mount /dev/sda8 /mnt

Once you’re sure that your root partition is correctly mounted in /mnt. Then mount EFI partition.

sudo mount /dev/sda1 /mnt/boot/efi

Again verify by navigating through cd or through the file manager.

Now you can chroot into the installed system.

sudo arch-chroot /mnt
1 Like

First, make sure you have read this:

Your EFI partition is /dev/sda1

Your root partition is probably either /dev/sda6 or /dev/sda8. You can probably tell which is which by the sizes.

Didn’t I answer it above?

Hi, you can downgrade grub to an earlier version (grub-2:2.06.r297). You have to boot by an USB drive, then mount your linux partition (watching your fdisk output, it seems to be named /dev/sda8). So type ‘sudo su’, ‘mount /dev/sda8 /mnt’, then ‘arch-chroot /mnt’. If arch-chroot is working, by typing ‘ls /home’ you can see your username as output. If so, type the following to downgrade grub: ‘pacman -U /var/cache/pacman/pkg/grub-2:2.06.r297.g0c6c1aff2-1-x86_64.pkg.tar.zst’. Then reboot.

Okay I feel totally stupid here…

sudo fdisk -l
Device             Start       End   Sectors   Size Type
/dev/nvme0n1p1 211814400 232785919  20971520    10G Linux filesystem
/dev/nvme0n1p2 232785920 976768031 743982112 354.8G Linux filesystem
/dev/nvme0n1p3   2099200 211814399 209715200   100G Linux filesystem
/dev/nvme0n1p4      2048   2099199   2097152     1G Microsoft basic data
[liveuser@eos-2022.08.05 ~]$ sudo efibootmgr
EFI variables are not supported on this system.
[liveuser@eos-2022.08.05 ~]$ sudo mount /dev/nvme0n1p4 /mnt/boot
[liveuser@eos-2022.08.05 ~]$ ls /mnt/boot
EFI
[liveuser@eos-2022.08.05 EFI]$ ls
boot  EndeavourOS  EndeavourOS-grub

I am pretty sure it should be an EFI System, but yeah when I tried the Grub Repair as described for EFI Systems, this is what happened, it told me at this step it wouldn’t be an EFI System… Can anyone point me on how to fix it?

I’m completely crushed with this damn Grub Update…

You need to boot the ISO in uefi mode. Some motherboards allow you to boot it in both legacy or UEFI modes.

How can I force to do that? When Booting I only get to select the USB Stick, or USB Stick Partition 1.

It depends on your hardware.

You might try mounting /dev/nvme0n1p4 and checking to see if it is an EFI partition. If it isn’t you are probably using BIOS/legacy boot.

Bios shows me definitly UEFi as first boot option.
And I found a setting to boot the Stick into UEFI seperately. Must have missed that.

I think I got it now. Thank you. At least the Commands worked this time now to reinstall Grub, without showing an Error. Now I’m off rebooting and hoping for the best.

1 Like

I have verified that the root partition is sda8, however when I run sudo mount /dev/sda1 /mnt/boot/efi I get this error:
image

I ran the sudo mount /dev/sda8 /mnt, but the error still occurs.

What does ls /mnt/boot show?

Strange…
image

How about ls /mnt

There’s my user folder where all the stuff lies.
image

It looks like your /home is mounted there. Not your /

Create the folders that are missing, before mounting:
sudo mkdir /mnt/boot && mkdir /mnt/boot/efi