Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

OK–I left it that way for better (in my own mind) housekeeping…

2 Likes

This sounds interesting @JKMooney
As I saw on your profile you are experienced and not so noob like me!
Just curious:

  • as systemd boot is part of the systemd, this means it is ALWAYS there and will NEVER break? (I mean much less prone to bugs and glitches?)

  • I am on BTRFS, Snapper, and only EOS installed, would it be OK with systemd boot?

  • How can I install and use systemd boot (to test, may stick with it but may revert back).

  • IF there is a system update that breaks things, can I still boot? Restore an earlier snapshot?

Any feed back highly appreciated!

Yes, I followed the same steps on my laptop and desktop.
The laptop booted fine afterwards but the desktop gave me this malloc notification.

Unfortunately, the system also has its own housekeeping. With the next grub package update, the original file will be recreated, with the result that two same files will be executed during grub config creation. You should rename the file to its original name.

Hello there!

I’m very sorry if this was answered before, I tried to follow the complete conversation.

I’m still a beginner with Linux and now have the following issue:

I cannot boot after this update like the others on a btrfs Luks encrypted system (thinkpad, 1 SSD).

Is it correct that the solution would be to boot a live system, chroot into OS and downgrade grub?

Or would it be different with my setup?

Thank you very much! :slight_smile:

1 Like

No need to downgrade grub, just reinstall it. Follow the instructions here:

2 Likes
sudo mount  /dev/sdb2  /mnt 
sudo mount  /dev/sdb1  /mnt/boot/efi
sudo arch-chroot /mnt

If your machine uses ext4, then the above should chroot in.
Change the drive identifier to match yours.

Then:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS

Important:

Type exit to leave the chroot. Reboot.

1 Like

I don’t think it does:

This might be useful, as it has a section on btrfs:
https://discovery.endeavouros.com/system-rescue/arch-chroot-for-efi-uefi-systems/2021/03/

2 Likes

Still on my first coffee - not awake :smiley:

2 Likes

I also had the grub_debug_malloc error.
You said that you verified that you were on UEFI and that put me on the right track to a solution.
It wasn’t clear to me from the instructions and all the reading and researching I did, that I had to boot the EndeavourOS USB iso in UEFI mode.
I kept booting in ‘normal’ mode and then after some hints like yours I realised I needed to boot the USB in UEFI mode and then the instructions for reinstalling Grub made perfect sense for my EFI system.
All is good for me now :slight_smile:
Finally!

1 Like

I’m assuming systemd boot will be less prone to glitches mainly because it’s simpler.

Not really tried BTRFS but I don’t see why it would not be fine.

I found Dalto’s tutorial to be pretty good ([Tutorial] Convert to systemd-boot - #122 by JKMooney). I went the “kernel-install” route but, if you’re thinking of reverting back, perhaps the “manual” approach might be better. In any event, I would read the article, make sure it makes sense to you (for example, can you run a shell script you cut and pasted to a file?), and decide if this is the approach for you.

Timestamp --restore does give an option to re-install grub so I suspect it would work.

I also did not initially realize that you could have more than one boot file installed in the boot sector. You need to go into your motherboard settings and make sure the correct one is selected. I now believe the “grub_debug_malloc” error is an indication you have the wrong boot file selected in the motherboard.

I am already doing it now! [Tutorial] Convert to systemd-boot - #138 by limotux
Hopefully I would be safe.

Welcome to :enos: fòrum @adjagu but many of us followed those instructions and it still did not work. So its not a one size fits all situation.

I clean installed Artemis ISO and that definitely worked.

I booted the ISO in UEFI anď still got that grub rescue prompt, so go figure.

Solved it with clean install of Artemis.

It seems that the solution for it for many people is to remove the old boot entry and set the boot order so that the new entry is first.

I didn’t read all of the thread but, I would like to share that; for my two computers I didn’t downgrade GRUB. I just reconfigured and reinstalled GRUB using arch-chroot, grub-mkconfig, and grub-install.

3 Likes

Yes, not downgrading grub is the recommended solution. See the pinned post.

Also, welcome to :enos: forum!!
:rocketa_purple: :enos_flag:

2 Likes

Normally, I would have my older “tinker-box” PC to use as a sandbox to try out troubleshooting approaches on. Unfortunately, that box is running vanilla Arch and booting BIOS and just didn’t have the issue with the GRUB update.

Where can I learn to do that? I have InsydeH20 BIOS v1, yep it’s old, but it has UEFI and secure boot disabled. I don’t see any options like you describe.

It may come in handy for future booting problems.

And yeah, it’s single boot. Only :enos: for me.