Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

The question is - what do Arch users do that is different to the “children of Arch”? (Us, Manjaro, Garuda etc).

Do they have a pacman hook that installs grub after update? In living memory I cannot remember having to do this. I started on Manjaro 2011 ish (very, very ish :smiley: ), so 11 or 12 years. Grub just worked, even after an update.

For the users running in the following error:

Error: symbol ‘grub_debug_malloc’ not found.
Entering rescue mode
grub rescue>

For me this was fixed by selecting the right efi boot entry in the bios. It is named “EndeavourOS-grub” if you followed the guide. The endeavouros-[number] entry that was selected previously is the broken one.

/cc @HMS_Endeavour , @JKMooney

3 Likes

Go into /boot/efi/EFI and delete the old entry with:

sudo rm -rf <old-entry-name>\

Make sure it is the correct entry! :rofl:

Look at the folder’s dates.

1 Like

My solution was to just use rEFInd, but keep grub. I can boot into GRUB by selecting the fallback bootloader option. I hid the grub entry in the endeavorOS-grub entry as it’s redundant and i’m not sure if it worked.

Now my Dad won’t say,

hey, there’s this weird menu on the screen, where’s windows, oh never mind son now it’s spitting text at me, ok now it’s done but I see this wallpaper that has the words “EndeavourOS Artemis Neo” on it plz help where’s google chrome how do I go into windows

when he inevitably needs to take my craptop for “business reasons”


Just like how one time my Dad called me and said

“I’m in windows and the internet isn’t working, plz help”

and then it turns out he booted into SAFE MODE on accident (i have the w7 style bootloader in my w10 install :wink: and windows 7’s bootloader picks safemode as the default option after choosing the OS, and w10 BL in w7 mode is the same :wink:)

and then he gets made when I laugh at his sheer, ahem, how can I not deface my Dad here, uhh, cluelessness.


Now when he inevitably takes my craptop for “business reasons” he can just move the mouse and take the blue pill.

Booting from fedora boot works.
Dual boot :wink:

@sradjoker what do you think about adding these to the steps here The latest grub package update needs some manual intervention

After

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

Maybe this?

cp /boot/efi/EFI/EndeavourOS-grub/grubx64.efi /boot/efi/EFI/boot/bootx64.efi

and maybe for clean up this (after you reboot and everything is working)

rm -r `ls /boot/efi/EFI | grep "endeavour" | grep -v 'EndeavourOS-grub'`

What do you think?

my ls /boot/efi/EFI/
gives me

endeavouros-5317

does that mean i should do

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

or

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=endeavouros-5317

?

just do sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

possible you get extras entrance gives anopther issue like

image

has to do on the boot order in buis or efibootmgr idk…

I think so but I have never tried that to be honest.

To be on the safe side, you can do the suggested

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

and then

cp /boot/efi/EFI/EndeavourOS-grub/grubx64.efi /boot/efi/EFI/boot/bootx64.efi

Maybe people with more knowledge on this can chime in.

The fix worked for me

this i dont know grub install should do but probably it follows the bootorder also
the system if you have multiple bootorder

Hi, I just fixed the issue using pinned post. I am simplifying here the steps that I followed:

I have EFI system installed on NVME.

  1. Boot into LIVE EndeavourOS environment using pen drive ( you can use your phone to download and burn iso on Pendrive using ETCHER app )

  2. sudo fdisk -l

  3. Look for the device list within the Disk section that is of Type EFI System (NOT Linux Filesystem)

  4. Now mount that device using sudo mount /dev/sdXn /mnt/boot/efi
    (Replace sdXn with which device has type EFI System) In my case, this command looked like
    sudo mount /dev/nvme0n1p1 /mnt/boot/efi

  5. Next, chroot on it: sudo arch-chroot /mnt

  6. Next, run this command to generate a new grub config file and replace the existing one:
    grub-mkconfig -o /boot/grub/grub.cfg

  7. Then, run this command to install grub with the new config file:
    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

  8. Finally Shutdown, remove Pendrive, and start normally.

Hope it helps someone :innocent:

3 Likes

I just hit this on an Arch install. The only thing needed to fix the problem is a grub-install.

2 Likes

there is no really simple way to give step by step instructions… because chrooting is different on how the system is set up… filesystem could be ext4 xfs and indeed BTRFS it could or could not include encrypted partitions or a full encryptions… and also manual partitions with a custom setup like LVM e.t.c

So the best way is to get to read the wiki tutorials and find what is needed on your setup.

6 Likes

Did you happen to have the grub-tools package from the EndeavourOS repo installed?

On an Arch install? No. :stuck_out_tongue_winking_eye:

1 Like

same here i done arch install reset grub and downgrade to the prior grub package reinstall grub stuff regenerate cfg file… reboot and do the update with exactly the same result that it goes directly into firmware setup…
doing grub-install solved it… not 100% but i can boot again after it…

What i see is that it could be also grub-theming is causing issues … so i would suggest to remove the grub theme in addition…

i tried removing them and there is no difference aside from i see the linux with linux on linux dancing with linux

1 Like

on some laptop also see efibootmgr you have more entries. that cause also 452 out of rfange pointer…

cleanup nvram change bootorder fix that because the grub name is changed.

yea i see at telegram… and io do also see similar if i do grub-install it does not create a new entry in my uefy firmware anymore… it was doing this before and sets it to boot as default is this the same?