Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

sorry, but I don’t understand what the next step is, you think I don’t get out of arch chroot?

I did all the steps and everything is as it was before the problem with the update, dalto BIG BIG THANKS!!! :wave: :wave: :wave: :wave: :wave: :wave: :wave:
is it enough to turn off grub from the updates or do you need to pay attention to something else?


Now that you have made it to r322, you don’t need to stop grub from updating.


I still couldn’t fix the out of range error.

I tried the fix described by this post. This got me to boot the endeavour menu where I can choose which kernel to boot. But after that the system will not boot. Instead I’ll get promoted with the out of range error.

Then I tidied up my efiboot entries with efibootmgr. I deleted old system entries and then got rid of endeavour entry as well. After that ran grup-install. efibootmgr -v shows me an endeavour entry on position 0000. I think this part should be fine, but no luck after rebooting. The issue still exists.

Please help me and thanks in advance.

i originally put this post in the arch linux discord and got no help.
also im new to this forum so i probably did something wrong

here is my discord post:

I have a pc I built at the beginning of the summer ryzen 5600x with a 1050 ti on a aorus pro wifi motherboard. I installed windows, and repeatedly failed installing arch ( I think I got the partitions mounted wrong or something ). I eventually gave up on arch and installed emdeavoros on the previously made partitions, with 500gb ish for windows and same for endeavor os. It worked great until yesterday, when I opened kde discover, updated the 350ish packages (I hadn’t updated in like a month, my bad…). When I rebooted for some of those updates to take effect, it booted into the uefi config menu (the one with the xmp profiles, fan speeds, etc). When i exited that menu, it booted right back into it. It is in a loop like that now. However, my motherboard has a nice feature that allows me to boot any bootloader on the device. It recognized a few. (See attached image). The first boots into a bootable media thing, the second boots into my motherboard config thing again, the third boots into windows, which is working perfectly fine, the fourth boots into rEFInd which is pictured below which boots 3 things: windows, one of my failed arch installations (which now is pretty broken) and the third boots into “EFI\endeavoros-6964\grubx64.efi” which boots back into the uefi config stuff. The fifth and final option is to boot into “endeavoros-6964” which again goes back into the uefi config stuff. Basically to conclude everything that should boot endeavoros boots into the uefi config instead. Any suggestions on how to fix my pc?



Try this:

and you have only one entry for endeavouros in the firmware or still more?
post the output of efibootmgr

I am pretty new to Linux and Arch. I dual boot EndeavourOS and Windows 10. I had the issue with grub causing my system to boot to bios.

I had tried to follow directions to get it working again, and eventually got it fixed. I’m pretty sure I ended up downgrading grub during the process. I also put grub on the pacman update ignore list as someone had suggested.

Today, having read that things were back in order, I updated my system, took grub off of the ignore list and installed it before rebooting. Now I have a similar problem to what was occurring initially…however, my system boots directly into Windows. I have attempted the steps of booting into the Live ISO, chroot into my install, and run grub-install. I’ve also ensured that my boot order is correct with efibootmgr.

When I reboot, I boot directly into Windows and grub never shows up. When I open my bios, the boot order is set to boot with Windows Boot Manager. There is no EndeavourOS option listed. Both OS’s are installed on the same hard drive.

Any suggestions to getting this up and booted again? Thanks for the help!

What does your Uefi boot-menu give you? Can you set the boot-order there?

Did you run the update grub command after reinstalling it?

1 Like

Turns out I could fix it in BIOS. When I first installed EndeavourOS, that’s how my boot option was listed in my bios. That had apparently changed to Windows Boot Manager. I didn’t realize (through some obscure menu options in my bios) that I could edit the Windows Boot Manager option to load up EndeavourOS with grub. It’s up and working again now.


I ran the grub-install initially after updating system before I had the boot issue again. I also ran chroot and updated grub that way.

Ends up I was able to change some boot options for “Windows Boot Manager” in my bios that I was unaware of. Now I’m booting correctly again. Thanks for the help!

1 Like

Yes, sometimes it’s just a matter of changing the boot order in UEFI. Other times it can be something else. You obviously did it correctly and just needed to set the boot option.


This grub issue is awful!



The error:

you removed uefi os ? , try to open bios and try select from there.

I can’t. The changes made with efibootmgr seem to not be permanent. I have a bunch of old stuff in my bios but no entry for endeavour. I try resetting settings in bios and switching to legacy boot now.

to look in boot menu, but more or less in bios my understanding efibootmgr showed ok…
uefi os is normal also there but thats hardware pointing to the standard boot i think not sure…

thats why you have to look intoo bios… pointing to legacy boot can have other issue later on ?

The problem seems to be that changes made with efibootmgr or by grub-install are not permanent. If I look in my boot-menu I didn’t see an entry for endeavour. If I reboot and do another chroot. I can find endeavour entry but it’s gone from position 1 in the boot order. So I can fix that or ran another grup-install. But after a reboot things are gone again.

Why could this be happening?