Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

could be the system is set to some fast boot feature? that simply do not show any boot options? and if you are booting directly into the system firmware you should be able to set system to boot from the USB stick there ? if not try loading the manual boot menu by pressing F12 ?

OMG! Just another grub update (-4); fingers crossed!

1 Like

Be sure to save the bios/uefi settings before reboot…
Good luck!

That one fixes the slow boot issue and perhaps the out of memory error some people have been seeing.

1 Like

Thanks @dalto , good to know!
It worked without problems, but did not update the grub screen during boot (was still showing “-3”). After login I had to run grub-install, rebooted and then it updated the boot screen to “-4”

Was able to fix the issue following posted instructions on a dual-boot laptop with the boot partition encrypted. Thanks for highlighting the issue (the transparency post) and ensuring the solution was readily available.

Only thing to note is that the initial screen for entering the LUKS password is not scaled correctly after applying the fix, but have more important things to worry about and just happy to be able to use Arch Linux as a daily machine.

Today, I Update the latest system,suddenly I have a problem about uefi guide failed,Now Endeavouros start failed,urgent,urgent,urgent!

I need your help ,Thank you very much!!!

1 Like


enter ISO environment,

sda2 is linux system, sda1 is EFI system

sudo fdisk -l 
sudo mount /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
sudo arch-chroot /mnt


it’s grub-install but that’s pretty much it, yes assuming those mount points match up to your install.

1 Like

Finally it appears that there was a bug at startup in relation avec the update. Unfortunatelly I mananged to boot normally only after having reformated the hard disc.

indeed this is working but not a solution to get the fully working and nicely configured OS to boot again.
And how do you get any OS booted to format the disk ?

Would be tempting to bust on Arch for just now getting around to posting this issue on their news feed but, I suppose I’ll be nice :wink:

I had to take the disk out of the computer and to reformat it using a cable and another computer.
Used GPARTED and it appears to work. The bad news is that by doing taht I’ve lost a bunch of files…
The big question is what went wrong after the update so that I never got it boot in live media…
If this could help - it is a LENOVO IDEAPAD with RYZEN 7 CPU.

We are by extension Arch, so we’d really just be busting on ourselves :wink:

(not being serious btw, only joking of course!)

The community is much friendlier than vanilla arch community.
I never liked vanilla much anyway, I prefer chocolate.

1 Like

That’s the main reason I’m here instead of there.


Brought back the colored (previous) grub menu

Do not know if it was necessary, but since these instructions were shown after update, I used them:
sudo grub-install…
sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

Hello community
I run today pacman syu and after can’t boot on system.
I checked this topic here: The latest grub package update needs some manual intervention and did instructions but at the stage where have to run grub-install says: /boot/efi doesn’t look like an EFI partition

Is your system uefi?