Great news for users with the latest AMD Ryzen

AMD has released a BIOS fix for their AMD Ryzen 3000 series to run with distros like Arch (thanks to Michael Nothing for bringing it to our attention)


For the information of other AMD users: I have an Asrock deskmini A300 with a Ryzen 2200G and I also have a celeron-based Intel NUC. I have installed Arch Linux many times and I recently tried EndeavourOS on my NUC and the Asrock A300. All went well until I accepted a large upgrade which included Linux Kernel Version 5.2.8 (upgraded from 5.2.7). The NUC was fine, but the Asrock started producing coloured artefacts everywhere the mouse went. I reinstalled vanilla Arch Linux on the Asrock and got the same effect. So, on my Asrock I reverted to the Linux 4.19 LTS kernel (still on vanilla Arch Linux) and peace and sanity was restored. I checked but there appears to be no AMD BIOS update for the 2200G, only for the 3000 series.

What Bios version are you running on the Asrock A300 Desktop mini?

I don’t know. I haven’t upgraded the BIOS because the last time I checked there was none available. My deskmini is the A300M -STX P1.20. I can find no spec for the BIOS in settings. The AMD is UEFI. There is only one other reference to the system in the BIOS Settings is the Microcode Update:

The problem with colour artefacts was caused by the xfwm4 update. The solution is contained in the Arch Linux wiki reference to it at

You run one of these:

xfwm4 --vblank=off --replace
xfwm4 --vblank=xpresent --replace
xfwm4 --vblank=glx --replace

The AMD Microcode has to do with the processor and security. The color artifact problem has to do with the updated xfce 4.14 version. The Uefi Bios update is not fom AMD but the motherboard manufacturer although indirectly it comes form AMD. So if it’s an Asrock product it comes from Asrock. If this is the correct product then your version is probably 1.20 which is the second release. There are more Bios updates on the Asrock site for the A300 Mini but they only describe a process of updating on Windows and it requires an updated AMD video driver first. Your graphics are onboard the processor and are AMD. If your on Linux you are probably using the open source drivers. So Im not sure if you are dual booting or just straight Linux. You can look at the information as i am NOT recommending you to do anything. Just wanted to clarify. If this is your product then the latest Bios is actually version 3.50

The UEFI Bios version will be listed in the Bios settings somewhere with the release date.

Thanks. The problem was to do with the xfce4.14 update, specifically the xfwm4 part and I solved it with the command line instruction above. My Asrock is Linux only and there is no current BIOS update for the AMD 2200G processor. I don’t intend to do anything since the system is working well. I have to admit that I have a pure Arch Linux installation on the Asrock, since there seems no point in reinstalling with endeavouros when I will just end up with the same system.

Glad things are working well for you. A Bios update is for the motherboard not for the processor. There may be updates that specifically relate to an issue with a certain processor or allow the motherboard to accept newer processors but it’s not for the processor. It fixes issues related to a lot of different things or upgrades it maybe to accept newer processors the board could not have been able to use prior. In the case of Amd it may also be for issues related to their GPU or power factors or memory timings etc. I have done many Bios updates over the years. Both on MBR and UEFI.