Graphics Issue. Intel Rocket Lake-S UHD 750

Big time Linux noob here. Finally decided to give it a go again because I’m getting a bit fed up with the state of privacy when it comes to the big 2 commercial players. Started by installing EndeavourOS on an old laptop just to mess around with a bit, and that went pretty well so I decided to “promote” it to my secondary desktop PC. My secondary PC is a Dell micro with an i5-11500T processor, which has UHD Graphics 750.

The issue I’m running in to on this system is that the screen doesn’t refresh in certain apps, I assume its any app that is trying to use hardware video acceleration. For example, if I launch Firefox or Brave web browser, the app launches fine, but then the screen remains static. If I resize the window, it will redraw during the resize and any changes that have occurred will be visible.

Similarly, if I run glxgears, the window appears and the terminal reports the fps, but the actual gears do not visibly spin. Again, if I resize the window, the gears will spin so long as I continually drag/resize the window border.

(hopefully) relevant system info stuff here below.

uname -sr
Linux 5.13.12-arch1-1

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation RocketLake-S GT1 [UHD Graphics 750] (rev 04)

glxinfo | grep “OpenGL renderer”
OpenGL renderer string: Mesa Intel(R) Graphics (RKL GT1)

sudo dmesg | grep i915
[ 1.500609] i915 0000:00:02.0: vgaarb: deactivate vga console
[ 1.503905] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 1.506986] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/rkl_dmc_ver2_02.bin (v2.2)
[ 1.541983] [drm] Initialized i915 1.6.0 20201103 for 0000:00:02.0 on minor 0
[ 1.544832] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 1.572640] fbcon: i915drmfb (fb0) is primary device
[ 1.658073] i915 0000:00:02.0: [drm] fb0: i915drmfb frame buffer device
[ 1.929460] mei_hdcp 0000:00:16.0-b638ab7e-94e2-4ea2-a552-d1c54b627f04: bound 0000:00:02.0 (ops i915_hdcp_component_ops [i915])

sudo lshw -c video
description: VGA compatible controller
product: RocketLake-S GT1 [UHD Graphics 750]
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 04
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list fb
configuration: depth=32 driver=i915 latency=0 mode=3840x2160 visual=truecolor xres=3840 yres=2160
resources: iomemory:600-5ff iomemory:400-3ff irq:154 memory:6000000000-6000ffffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff

It would be better for you to post the following link for your hardware. I think this chip has Intel Iris graphics. You could try removing xf86-video-intel and run modesetting with the kernel driver.

inxi -Faz --no-host | eos-sendlog

1 Like

Sounds like it could be a kernel issue, an Xorg/Wayland issue, or a hardware issue. The easiest thing to try is using the LTS kernel instead of the 5.13 kernel and seeing if that changes anything for you.

To install the LTS kernel, run these two commands one at a time:

sudo pacman -S linux-lts
sudo pacman -S linux-lts-headers

You’ll have to do a reboot, and then select the LTS kernel during the grub boot, aka before your computer loads up into the login screen. Give that a try first and let us know how that goes.

Also it’s helpful to know what desktop environment are you running?

1 Like


Try sudo pacman -S intel-media-driver vulkan-intel
and create a xorg config file in /etc/X11/xorg.conf.d/20-intel.conf
with the following parameters

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "AccelMethod"  "uxa"
  Option "DRI" "2"

P.S. 20-intel.conf is the name of the file

Thanks! Things seem to be working with the 5.10 lts kernel.


With that .conf file in place after installing the specified packages, I was unable to boot into the graphical environment at all. Had to remove it in order to get back into xfce.

1 Like

That was a possibility, probably Option "AccelMethod" "uxa" parameter/acceleration method is no longer supported by your gpu. Anyway mark scottys post as the solution and enjoy your new installation! :smiley:

This is just goes to show you that not everything works. You have to try something first and if it doesn’t revert back and try something else until you find a workable solution.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.