Graphic Problems after System Update

I just encountered a weird issue after updating my system and my noobie troubleshooting skills failed me.

My Laptop has an AMD Processor with integrated GPU and an Nvidia RTX 4090 (Advanced Optimus). Im using the latest version of Gnome and installed the new Nvidia 555 Beta drivers. Everything has been working incredibly well, until updating a few days ago.

After updating my system all my external monitors stopped working and didnt get recognized anymore and I also couldnt load into X11 anymore (after entering the password the screen filickers and Im back in the login screen) only wayland works.
Seemed to be an issue with the nvidia persistent driver that was not easy to solve, so I tried to go back to the 550 drivers for testing.
Now the Wayland option in GDM is gone entirely but my monitors work again.

I just rolled back with Timeshift to get a working state but this probably isnt a long lasting solution. Any advice how I can troubleshoot it the best?

I tried excluding some driver related packages from the update but this didnt work, I might have missed some. Here is the list of updated packages in case it helps:

[2024-06-22T18:41:16+0200] [ALPM] upgraded archlinux-keyring (20240520-1 -> 20240609-1)
[2024-06-22T18:41:50+0200] [ALPM] upgraded alsa-ucm-conf (1.2.11-1 -> 1.2.12-1)
[2024-06-22T18:41:50+0200] [ALPM] upgraded alsa-lib (1.2.11-1 -> 1.2.12-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded alsa-plugins (1:1.2.7.1-2 -> 1:1.2.12-2)
[2024-06-22T18:41:51+0200] [ALPM] upgraded hwdata (0.382-1 -> 0.383-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded xz (5.6.1-3 -> 5.6.2-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded openssl (3.3.0-1 -> 3.3.1-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded pciutils (3.12.0-1 -> 3.13.0-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded alsa-utils (1.2.11-1 -> 1.2.12-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded amd-ucode (20240510.b9d2bf23-1 -> 20240610.9c10a208-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded aom (3.9.0-1 -> 3.9.1-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded pcre2 (10.43-4 -> 10.44-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded glib2 (2.80.2-2 -> 2.80.3-2)
[2024-06-22T18:41:51+0200] [ALPM] upgraded libgpg-error (1.49-1 -> 1.50-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded libgcrypt (1.10.3-1 -> 1.11.0-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded systemd-libs (255.7-1 -> 256.1-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded nettle (3.9.1-1 -> 3.10-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded libcups (2:2.4.8-1 -> 2:2.4.10-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded libdrm (2.4.120-1 -> 2.4.121-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded libevdev (1.13.1-1 -> 1.13.2-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded cryptsetup (2.7.2-1 -> 2.7.3-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded findutils (4.9.0-3 -> 4.10.0-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded ca-certificates-utils (20220905-1 -> 20240618-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded ca-certificates-mozilla (3.100-1 -> 3.101-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded ca-certificates (20220905-1 -> 20240618-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded libnghttp3 (1.3.0-1 -> 1.4.0-1)
[2024-06-22T18:41:51+0200] [ALPM] upgraded systemd (255.7-1 -> 256.1-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libwacom (2.11.0-1 -> 2.12.2-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libinput (1.25.0-1 -> 1.26.0-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libproxy (0.5.6-1 -> 0.5.7-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libxml2 (2.12.7-1 -> 2.13.1-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded wayland (1.22.0-1 -> 1.23.0-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded xkeyboard-config (2.41-1 -> 2.42-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libedit (20230828_3.1-1 -> 20240517_3.1-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded mesa (1:24.0.8-1 -> 1:24.1.1-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded qt6-base (6.7.1-2 -> 6.7.1-4)
[2024-06-22T18:41:53+0200] [ALPM] upgraded attica (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded fribidi (1.0.14-1 -> 1.0.15-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libogg (1.3.5-1 -> 1.3.5-2)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libwireplumber (0.5.2-2 -> 0.5.3-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded wireplumber (0.5.2-2 -> 0.5.3-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libopenmpt (0.7.7-1 -> 0.7.8-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded spirv-tools (2024.1-1 -> 2024.2-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded glslang (14.1.0-1 -> 14.2.0-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded shaderc (2024.0-1 -> 2024.1-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded libplacebo (6.338.2-6 -> 6.338.2-7)
[2024-06-22T18:41:53+0200] [ALPM] upgraded sdl2 (2.30.3-1 -> 2.30.4-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded x264 (3:0.164.r3108.31e19f9-1 -> 3:0.164.r3108.31e19f9-2)
[2024-06-22T18:41:53+0200] [ALPM] upgraded x265 (3.5-3 -> 3.6-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded highway (1.1.0-1 -> 1.2.0-1)
[2024-06-22T18:41:53+0200] [ALPM] upgraded pango (1:1.52.2-1 -> 1:1.54.0-1)
[2024-06-22T18:41:54+0200] [ALPM] upgraded python (3.12.3-1 -> 3.12.4-1)
[2024-06-22T18:41:54+0200] [ALPM] upgraded ffmpeg (2:6.1.1-7 -> 2:7.0.1-1)
[2024-06-22T18:41:54+0200] [ALPM] upgraded audacious-plugins (4.3.1-3 -> 4.4-1)
[2024-06-22T18:41:54+0200] [ALPM] upgraded freeglut (3.4.0-1 -> 3.6.0-1)
[2024-06-22T18:41:54+0200] [ALPM] upgraded audacious (4.3.1-1 -> 4.4-1)
[2024-06-22T18:41:54+0200] [ALPM] upgraded bash-completion (2.11-3 -> 2.14.0-2)
[2024-06-22T18:41:54+0200] [ALPM] upgraded bolt (0.9.7-2 -> 0.9.8-1)
[2024-06-22T18:41:56+0200] [ALPM] upgraded breeze-icons (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:41:56+0200] [ALPM] upgraded btrfs-progs (6.8.1-1 -> 6.9-1)
[2024-06-22T18:41:56+0200] [ALPM] upgraded libxslt (1.1.39-2 -> 1.1.41-1)
[2024-06-22T18:41:56+0200] [ALPM] upgraded chafa (1.14.0-3 -> 1.14.1-1)
[2024-06-22T18:41:56+0200] [ALPM] upgraded chromaprint (1.5.1-7 -> 1.5.1-8)
[2024-06-22T18:41:56+0200] [ALPM] upgraded cmake (3.29.3-1 -> 3.29.6-1)
[2024-06-22T18:41:56+0200] [ALPM] upgraded nspr (4.35-2 -> 4.35-3)
[2024-06-22T18:41:56+0200] [ALPM] upgraded nss (3.100-1 -> 3.101-1)
[2024-06-22T18:41:56+0200] [ALPM] upgraded poppler (24.05.0-1 -> 24.06.1-1)
[2024-06-22T18:41:56+0200] [ALPM] upgraded qpdf (11.9.0-1 -> 11.9.1-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded cups (2:2.4.8-1 -> 2:2.4.10-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded discord (0.0.54-1 -> 0.0.57-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded libphobos (1:2.108.1-1 -> 1:2.109.0-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded dmd (1:2.108.1-1 -> 1:2.109.0-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded dracut (101-1 -> 102-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded editorconfig-core-c (0.12.7-1 -> 0.12.9-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded ell (0.65-1 -> 0.66-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded enchant (2.7.3-2 -> 2.8.0-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded endeavouros-mirrorlist (24.4-1 -> 24.6.4-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded endeavouros-theming (24.04.1.2-1 -> 24.04.1.3-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded eos-translations (24.4.8-1 -> 24.6-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded gstreamer (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:41:57+0200] [ALPM] upgraded gst-plugins-base-libs (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:41:57+0200] [ALPM] upgraded gst-plugins-bad-libs (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:41:57+0200] [ALPM] upgraded woff2 (1.0.2-4 -> 1.0.2-5)
[2024-06-22T18:41:57+0200] [ALPM] upgraded yad (13.0-2.2 -> 14.0-1.1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded eos-bash-shared (24.16.9-1 -> 24.16.12-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded eos-packagelist (2.2.1-1 -> 2.3-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded eos-rankmirrors (24.4-1 -> 24.6.1-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded eos-settings-gnome (2.1-1 -> 2.2-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded ethtool (1:6.7-1 -> 1:6.9-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded exfatprogs (1.2.3-1 -> 1.2.4-1)
[2024-06-22T18:41:57+0200] [ALPM] upgraded fakeroot (1.34-1 -> 1.35-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded fastfetch (2.13.2-1 -> 2.16.0-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded ffmpeg4.4 (4.4.4-5 -> 4.4.4-6)
[2024-06-22T18:41:58+0200] [ALPM] upgraded ffmpegthumbnailer (2.2.2-5 -> 2.2.2-6)
[2024-06-22T18:41:58+0200] [ALPM] upgraded noto-fonts (1:24.5.1-1 -> 1:24.6.1-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded firefox (126.0-1 -> 127.0.1-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded frei0r-plugins (2.3.2-2 -> 2.3.3-2)
[2024-06-22T18:41:58+0200] [ALPM] upgraded fzf (0.52.0-1 -> 0.53.0-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded gcr (3.41.2-1 -> 3.41.2-2)
[2024-06-22T18:41:58+0200] [ALPM] upgraded gcr-4 (4.2.1-2 -> 4.3.0-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded libgdm (46.0-1 -> 46.2-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded libnm (1.46.0-2 -> 1.48.0-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded libdisplay-info (0.1.1-3 -> 0.2.0-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded libtool (2.5.0+1+g38c166c8-1 -> 2.5.0+14+g9a4a0261-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded libimobiledevice-glue (1.2.0-1 -> 1.3.0-1)
[2024-06-22T18:41:58+0200] [ALPM] upgraded mutter (46.2-1 -> 46.2-3)
[2024-06-22T18:41:58+0200] [ALPM] upgraded unzip (6.0-20 -> 6.0-21)
[2024-06-22T18:41:59+0200] [ALPM] upgraded js115 (115.11.0-1 -> 115.12.0-1)
[2024-06-22T18:41:59+0200] [ALPM] upgraded gdm (46.0-1 -> 46.2-1)
[2024-06-22T18:41:59+0200] [ALPM] upgraded poppler-glib (24.05.0-1 -> 24.06.1-1)
[2024-06-22T18:41:59+0200] [ALPM] upgraded gegl (0.4.48-3 -> 0.4.48-4)
[2024-06-22T18:41:59+0200] [ALPM] upgraded git (2.45.1-1 -> 2.45.2-1)
[2024-06-22T18:41:59+0200] [ALPM] upgraded python-typing_extensions (4.12.0-1 -> 4.12.2-1)
[2024-06-22T18:41:59+0200] [ALPM] upgraded python-pydantic-core (1:2.18.2-2 -> 1:2.18.4-1)
[2024-06-22T18:41:59+0200] [ALPM] upgraded python-pydantic (2.7.1-2 -> 2.7.4-1)
[2024-06-22T18:41:59+0200] [ALPM] upgraded glances (4.0.7-1 -> 4.0.8-2)
[2024-06-22T18:42:00+0200] [ALPM] upgraded glib2-docs (2.80.2-2 -> 2.80.3-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded go (2:1.22.3-1 -> 2:1.22.4-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded go-tools (4:0.21.0-1 -> 4:0.22.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded groff (1.23.0-5 -> 1.23.0-6)
[2024-06-22T18:42:01+0200] [ALPM] upgraded grub-btrfs (4.13-1 -> 4.13-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded gsl (2.7.1-3 -> 2.8-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded gst-libav (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded gst-plugin-gtk (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded libde265 (1.0.15-1 -> 1.0.15-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded openal (1.23.1-1 -> 1.23.1-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded gst-plugins-bad (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded gst-plugins-base (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded gst-plugins-good (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded gst-plugins-ugly (1.24.3-1 -> 1.24.5-2)
[2024-06-22T18:42:01+0200] [ALPM] upgraded gtksourceview5 (5.12.0-1 -> 5.12.1-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded perl-alien-build (2.80-2 -> 2.83-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded hplip (1:3.23.12-6 -> 1:3.24.4-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded inxi (3.3.34.1-1 -> 3.3.35.1-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded iwd (2.17-2 -> 2.18-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kconfig (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kcodecs (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kguiaddons (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded ki18n (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kcolorscheme (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kcoreaddons (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kwidgetsaddons (6.2.2-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kconfigwidgets (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded karchive (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kwindowsystem (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kauth (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kbookmarks (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kcompletion (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kcrash (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kdbusaddons (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kiconthemes (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kitemviews (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded knotifications (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kjobwidgets (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kservice (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded kwallet (6.2.1-1 -> 6.3.0-1)
[2024-06-22T18:42:01+0200] [ALPM] upgraded solid (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kio (6.2.0-2 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kirigami (6.2.1-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kglobalaccel (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kxmlgui (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kcmutils (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded signon-kwallet-extension (24.05.0-1 -> 24.05.1-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded qt6-webengine (6.7.1-1 -> 6.7.1-3)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kaccounts-integration (24.05.0-1 -> 24.05.1-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded poppler-qt6 (24.05.0-1 -> 24.06.1-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kfilemetadata (6.2.0-1 -> 6.3.0-2)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kpackage (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded syndication (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded knewstuff (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded knotifyconfig (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded sonnet (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded qt6-multimedia-ffmpeg (6.7.1-2 -> 6.7.1-3)
[2024-06-22T18:42:02+0200] [ALPM] upgraded qt6-multimedia (6.7.1-2 -> 6.7.1-3)
[2024-06-22T18:42:02+0200] [ALPM] upgraded ktextwidgets (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded mlt (7.24.0-1 -> 7.24.0-3)
[2024-06-22T18:42:02+0200] [ALPM] upgraded purpose (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded qqc2-desktop-style (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kdenlive (24.05.0-1 -> 24.05.1-2)
[2024-06-22T18:42:02+0200] [ALPM] upgraded kimageformats (6.2.0-1 -> 6.3.0-1)
[2024-06-22T18:42:02+0200] [ALPM] upgraded qt5-translations (5.15.13-1 -> 5.15.14-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded qt5-base (5.15.13+kde+r147-1 -> 5.15.14+kde+r141-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libkdcraw5 (24.05.0-1 -> 24.05.1-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded qt5-declarative (5.15.13+kde+r30-1 -> 5.15.14+kde+r28-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded qt5-svg (5.15.13+kde+r6-1 -> 5.15.14+kde+r5-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded qt5-x11extras (5.15.13-1 -> 5.15.14-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded qt5-wayland (5.15.13+kde+r60-1 -> 5.15.14+kde+r58-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded minizip-ng (4.0.5-1 -> 4.0.7-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded krita (5.2.2-9 -> 5.2.2-10)
[2024-06-22T18:42:03+0200] [ALPM] upgraded talloc (2.4.2-2 -> 2.4.2-3)
[2024-06-22T18:42:03+0200] [ALPM] upgraded ldb (2:2.9.0-3 -> 2:2.9.1-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libbpf (1.3.0-1 -> 1.4.2-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libheif (1.17.6-5 -> 1.17.6-6)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libmaxminddb (1.9.1-1 -> 1.10.0-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libmediainfo (24.04-1 -> 24.05-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libnautilus-extension (46.2-1 -> 46.2-2)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libndp (1.8-1 -> 1.8-2)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libngtcp2 (1.5.0-1 -> 1.6.0-1)
[2024-06-22T18:42:03+0200] [ALPM] upgraded protobuf (25.3-4 -> 27.1-2)
[2024-06-22T18:42:03+0200] [ALPM] upgraded libphonenumber (1:8.13.36-1 -> 1:8.13.39-1)
[2024-06-22T18:42:05+0200] [ALPM] upgraded libreoffice-fresh (24.2.3-3 -> 24.2.4-2)
[2024-06-22T18:42:05+0200] [ALPM] upgraded libsodium (1.0.19-3 -> 1.0.20-1)
[2024-06-22T18:42:05+0200] [ALPM] upgraded libwbclient (4.20.1-2 -> 4.20.2-1)
[2024-06-22T18:42:05+0200] [ALPM] upgraded linux (6.9.2.arch1-1 -> 6.9.5.arch1-1)
[2024-06-22T18:42:05+0200] [ALPM] upgraded linux-firmware-whence (20240510.b9d2bf23-1 -> 20240610.9c10a208-1)
[2024-06-22T18:42:05+0200] [ALPM] upgraded linux-firmware (20240510.b9d2bf23-1 -> 20240610.9c10a208-1)
[2024-06-22T18:42:05+0200] [ALPM] upgraded pahole (1:1.26-2 -> 1:1.27-1)
[2024-06-22T18:42:06+0200] [ALPM] upgraded linux-headers (6.9.2.arch1-1 -> 6.9.5.arch1-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded man-pages (6.8-1 -> 6.9.1-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded mbedtls (3.5.2-1 -> 3.6.0-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded mediainfo (24.04-1 -> 24.05-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded meson (1.4.0-5 -> 1.4.1-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded mtools (1:4.0.43-1 -> 1:4.0.44-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded nautilus (46.2-1 -> 46.2-2)
[2024-06-22T18:42:07+0200] [ALPM] upgraded networkmanager (1.46.0-2 -> 1.48.0-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded openvpn (2.6.10-1 -> 2.6.11-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded networkmanager-openvpn (1.10.4-1 -> 1.12.0-1)
[2024-06-22T18:42:07+0200] [ALPM] upgraded nodejs (22.2.0-1 -> 22.3.0-1)
[2024-06-22T18:42:08+0200] [ALPM] upgraded noto-fonts-cjk (20230817-1 -> 20230817-2)
[2024-06-22T18:42:08+0200] [ALPM] upgraded noto-fonts-extra (1:24.5.1-1 -> 1:24.6.1-1)
[2024-06-22T18:42:08+0200] [ALPM] upgraded ntp (4.2.8.p17-1 -> 4.2.8.p18-1)
[2024-06-22T18:42:08+0200] [ALPM] upgraded obs-studio (30.1.2-1 -> 30.1.2-2)
[2024-06-22T18:42:09+0200] [ALPM] upgraded opencv (4.9.0-8 -> 4.10.0-2)
[2024-06-22T18:42:09+0200] [ALPM] upgraded osinfo-db (20240510-1 -> 20240523-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded parallel (20240322-1 -> 20240522-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded python-cairo (1.26.0-2 -> 1.26.1-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded python-pikepdf (8.15.1-2 -> 9.0.0-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded pdfarranger (1.10.1-2 -> 1.11.0-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded perl-html-tagset (3.20-14 -> 3.24-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded pv (1.8.9-1 -> 1.8.10-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded python-fastjsonschema (2.19.1-3 -> 2.20.0-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded python-typeguard (4.2.1-2 -> 4.3.0-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded python-jaraco.text (3.12.0-3 -> 3.12.1-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded python-mako (1.3.3-3 -> 1.3.5-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded python-requests (2.32.2-1 -> 2.32.3-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded python-shtab (1.6.5-2 -> 1.7.1-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded qt5-graphicaleffects (5.15.13-1 -> 5.15.14-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded qt5-imageformats (5.15.13+kde+r7-1 -> 5.15.14+kde+r7-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded qt5-quickcontrols2 (5.15.13+kde+r5-1 -> 5.15.14+kde+r5-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded qt5-tools (5.15.13+kde+r4-1 -> 5.15.14+kde+r4-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded rebuild-detector (4.4.3-2 -> 4.4.3-3)
[2024-06-22T18:42:09+0200] [ALPM] upgraded reflector-simple (2023-4 -> 2024-1)
[2024-06-22T18:42:09+0200] [ALPM] upgraded rust (1:1.78.0-1 -> 1:1.79.0-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded signal-desktop (7.10.0-1 -> 7.12.0-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded smbclient (4.20.1-2 -> 4.20.2-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded systemd-resolvconf (255.7-1 -> 256.1-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded systemd-sysvcompat (255.7-1 -> 256.1-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded telegram-desktop (5.0.2-2 -> 5.1.7-2)
[2024-06-22T18:42:10+0200] [ALPM] upgraded vte-common (0.76.2-1 -> 0.76.3-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded vte3 (0.76.2-1 -> 0.76.3-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded xapp (2.8.2-2 -> 2.8.3-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded timeshift (24.01.1-1 -> 24.06.2-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded tor (0.4.8.11-1 -> 0.4.8.12-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded transmission-gtk (4.0.5-1 -> 4.0.6-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded vlc (3.0.20-9 -> 3.0.21-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded vpnc (1:0.5.3.r526.r213-1 -> 1:0.5.3.r539.r239-1)
[2024-06-22T18:42:10+0200] [ALPM] upgraded welcome (24.5.10-1 -> 24.6-1)
[2024-06-23T10:06:46+0200] [ALPM] upgraded gtk2 (2.24.33-3 -> 2.24.33-4)
[2024-06-23T10:06:46+0200] [ALPM] upgraded linux (6.9.5.arch1-1 -> 6.9.6.arch1-1)
[2024-06-23T10:06:47+0200] [ALPM] upgraded linux-headers (6.9.5.arch1-1 -> 6.9.6.arch1-1)
[2024-06-23T10:06:47+0200] [ALPM] upgraded mesa (1:24.1.1-1 -> 1:24.1.2-1)
[2024-06-23T10:06:47+0200] [ALPM] upgraded totem-pl-parser (3.26.6-2 -> 3.26.6+r30+g51b8439-1)
[2024-06-23T10:37:08+0200] [ALPM] upgraded mutter (46.1-1 -> 46.2-3)
[2024-06-23T10:44:12+0200] [ALPM] upgraded linux (6.9.2.arch1-1 -> 6.9.6.arch1-1)
[2024-06-23T10:44:12+0200] [ALPM] upgraded linux-firmware-whence (20240510.b9d2bf23-1 -> 20240610.9c10a208-1)
[2024-06-23T10:44:13+0200] [ALPM] upgraded linux-firmware (20240510.b9d2bf23-1 -> 20240610.9c10a208-1)
[2024-06-23T10:44:13+0200] [ALPM] upgraded linux-headers (6.9.2.arch1-1 -> 6.9.6.arch1-1)
[2024-06-23T10:44:13+0200] [ALPM] upgraded mesa (1:24.0.8-1 -> 1:24.1.2-1)
[2024-06-23T11:01:21+0200] [ALPM] upgraded firefox (126.0-1 -> 127.0-1)

The solution for every poor soul ending up here:

The issue was with the /usr/lib/udev/rules.d/61-gdm.rules

I had to comment out all the lines to get gnome to work with wayland initially and one of the upgraded packages did reset it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.