Gnome User Admin Missing

I just notice tonight on XFCE that the user GUI is missing and cannot change users or login. I have not been able to install Gnome-User-Admin program as the library for it will not even download and times out. I have tried a couple of other programs but they always fail during install. Any ideas as to why it was remove or how to fix the problem?

Voortzetting van de discussie Gnome User Admin Missing:

I am not yet used how to use the forum. But want to react on the issue.

The issue is the liboobs package not having the right url to download from.

Change the url in the liboobs PKG to
source=("https://download.gnome.org/sources/liboobs/3.0/${pkgname}-${pkgver}.tar.bz2")

Hope this helps.

1 Like

I have been out of town for a few days and was going to try your idea but seems that the app is no longer in the repository. I found another app called system user admin but it fails to install do to an error. I did find some information on how to do it manually but the information is rather old so I am leary to try it. Basically I only need to have the system ask for a password at startup.

do you mean like ::: to login to another user account.


When you install Gnome user admin with yay, you need to edit the package LIBOOBS, before installing Gnome User Admin.

Editing the package can also be done with Pamac-ui. User friendly way.
Otherwise you can read man page.

  • How to edit package with yay before installation.

$ man yay [look for --editmenu].

You need to change the download address from a FTP to a HTTPS url.

Change the url to :::

source=("https://download.gnome.org/sources/liboobs/3.0/${pkgname}-${pkgver}.tar.bz2")

After liboobs installed you can install Gnome user admin. :robot:

ericbandrakim thanks for the info but unfortunately I did the change and it downloaded but failed with an error during the build. Guess I an just out of luck.

Just for the check.
Do you have gnome-system-tools installed.

I couldn’t believe the url change would not work. That’s why the extra explanation of edit the pkgbuild. :space_invader:
Afterwards not needed.

Post the error for a better :eyes:

Like I said Gnome-use-admin no longer shows up in the repository. Looks like I will have to do a fresh install of KDE since it still has the users editor in it. As for the error, it happens when yay tries to compile one of the components connected with the library.

Look for

$ yay gnome-system-tools

Edit URL liboobs package again during install of gnome-system-tools.

Liboobs should look like this :: source url

$Id: PKGBUILD 104268 2014-01-16 18:44:14Z flexiondotorg $

Maintainer: Martin Wimpress code@flexion.org

pkgname=liboobs
pkgver=3.0.0
pkgrel=3
pkgdesc=“GObject based interface to system-tools-backends - shared library”
arch=(‘i686’ ‘x86_64’)
url=“http://developer.gnome.org/liboobs/
license=(‘GPL2’)
depends=(‘system-tools-backends’)
source=(“https://download.gnome.org/sources/liboobs/3.0/${pkgname}-${pkgver}.tar.bz2”)
sha256sums=(‘1e7a327df7dcfa30e0cd3e0d2ffcd9a2c91c7870291dd30434b5da907945c00a’)

build() {
cd “${srcdir}/${pkgname}-${pkgver}”
./configure
–prefix=/usr
–disable-static
make
}
package() {
cd “${srcdir}/${pkgname}-${pkgver}”
make DESTDIR="${pkgdir}" install
}

Edit → add pkg info liboobs