Gnome shell extensions stopped opening

Hey guys

I recently noticed that the gnome shell extensions stopped opening on EndeavorOS with Gnome 41.5.

See: ( )

Even though extensions is a part of gnome shell

The same extensions is well known for their erratic behavior and this is usually not caused by the distribution but upstream Gnome.

I remember using Antergos and Gnome and it was a problem then as it is now.

1 Like

Doesn’t work for me either. It’ll prob start working again once Arch updates the Gnome stack to 42, so until then you can use the Extension website listed above. Or the option I use that’s working is to use the newer extension app called Extensions Manager. You can check it out here:

It’s essentially the Extensions website features in a GTK4 app, and works perfectly. You can install it from the AUR or a flatpak:

yay -S extension-manager



1 Like

Try to set
before starting gnome-extensions-app


Absolutely the main reason why after close to two decades of being a Gnomehead, I switched to KDE Plasma. This will happen every six months when the Gnome version changes. So get used to it.



Hey guys

There were just over 12 updates today and the default Gnome extensions are back working.

1 Like

Since the issue seems to have been unrelated to EnOS, so if you don’t mind I have changed slightly the title of the topic. Hope you don’t mind and glad it got sorted out for you.