Gnome-session-quit

The native menu $mod+d+e to either lock, hibrnate,logout,reboot,shutdown does not do the lock, hibernate, sleep
so i tried

@EndevourOS ~]$ gnome-session-quit 

** (gnome-session-quit:20366): WARNING **: 14:32:55.176: Failed to call logout: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

with no success
how do i lock, sleep, hibernate from terminal???

Shouldn’t that be $mod+shift+e ?

Also, the commands to be run in the terminal seem to be the following:

 systemctl poweroff ## shutdown
 systemctl reboot ## reboot
 systemctl suspend ## sleep aka suspend to RAM
 systemctl hibernate ## hibernate aka suspend to disk
 ~/.config/i3/scripts/blur-lock  ## lock
 3-msg exit ## logout

Reference:

https://github.com/endeavouros-team/endeavouros-i3wm-setup/blob/main/.config/i3/config

https://github.com/endeavouros-team/endeavouros-i3wm-setup/blob/main/.config/i3/scripts/powermenu

2 Likes

Yes. It was mindless typing on my behalf.
And thanks for all the system ctrl options.
I might do some aliases to make it shorter.
Thanks

if you run gnome + i3wm you might think about ( as post in Desktop Environments i3wm )

Warning: if you install EndeavourOS-i3 aside with a full DE (XFCE4, GNOME, Plasma e.t.c.)

you need to comment out dex starter from ~/.config/i3/config file !!!

#exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart/

" https://discovery.endeavouros.com/window-tiling-managers/i3-wm/2021/03/ "

2 Likes