Gnome missing after reboot

Hello, Sorry of this is the wrong section, hopefully someone can help… My system was installed using the default calamares installer with encryption. been trying eos for about a week and after a reboot gnome seems to be missing. Im using a live USB at the moment to write this.

Eos 6.2.6-arch-1
Gnome DE
Btrfs with full drive encryption.

OK so I’m not an expert in Linux, I used MX Linux for a year and thought I’d try an arch distro. I don’t know a lot of terminal commands so please go easy. Things started getting strange a few days ago, Gnome files (gnome default file manager) disappeared from apps, and then jellyfin, then today it all went wrong.

So I was installing a flatpak using the Bauh package GUI thing and the system locked up with 100% CPU usage so I rebooted. It got stuck rebooting, but after 3 mins or so it finally rebooted.

Now when it boots after grub it just goes to the terminal but no DE. I ran Yay, and I have an internet connection but it fails on PGP keys. the message is… Error: required key missing from keyring.

I had installed timeshift, and I think I made a snapshot about 2 days ago, but the linked snapshot in grub no longer exists and not sure if it’s possible to restore from terminal using timeshift, or if it’s the best thing to try first. Does anyone have any advice or links that might help me?

hope someone can help. thanks

Hi onojo,

Let’s try a logical, sequential approach of your problem. You complain that gnome is missing after the reboot.

What does the command

$ sudo pacman -Ss gnome (you can use yay or paru instead of pacman, but that’s a matter of taste. I prefer paru, it runs over rust and it automates some of the operations)

return to you ? Certainly you boot using a window manager (WM), which should be sddm or other, that you currently can not use. You could launch the WM by hand (using $ startx) but you should have an .xinitrc file in your home directory. Try
$ ls -a

and seek for it. If not, install the xorg-xinit package, copy the /etc/X11/xinit/xinitrc into .xinitrc in your home directory. Edit it using nano, vim or inside Midnight Commander. You should add an entry

exec gnome-session

at the end of it and disable twm that is called by default.
Gnome setting

Until you get used to the system I would boot manually, to set you on a learning curve. And as a person not quite accustomed to Arch, I would give up encryption for some time, until you have a better grasp of the system. If all the above fails, I’m afraid you would have to reinstall the system.

But cheer up, you are in the purple world where everything is wonderful!

Best of luck!

You can arch-chroot into the system from your live usb.
Then, first thing is update the keyring:
sudo pacman -S archlinux-keyring

Next, a full update:

Next, run grub-install and grub-update, depending on your system.


thank you for the quick replies

I tried both approaches, but was still getting “required key missing from keyring” not sure if it is a hardware issue as my NVME might be failing.

In the end i restored using timeshift snapshot and backing up my data now in case it happens again.

Thank you for the help, and the warm welcome to the forum.