Gnome & Budgie will not boot up

I have just finished some Arm install testing. With Odroid N2+ all 10 DEs / WMs worked.

With the Rapsberry Pi 4 series, Gnome and Budgie will not boot up. The other 8 DEs / WMs worked as expected.

I’m starting with Gnome. It boots up until it gets to where GDM tries to start, and the white screen with the “Oops, something went wrong. Please log out and try again” message.

In tty console, entering systemctl status gdm.service yields the following:

● gdm.service - GNOME Display Manager
     Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2021-04-25 19:03:56 MDT; 4min 5s ago
   Main PID: 345 (gdm)
      Tasks: 3 (limit: 4915)
        CPU: 151ms
     CGroup: /system.slice/gdm.service
             └─345 /usr/bin/gdm

Apr 25 19:03:56 RPi4 systemd[1]: Starting GNOME Display Manager...
Apr 25 19:03:56 RPi4 systemd[1]: Started GNOME Display Manager.
Apr 25 19:04:35 RPi4 gdm[345]: Gdm: GdmDisplay: Session never registered, failing

The last line says “Session never registered, failing”
Never registered with what? I am kind of thinking maybe PAM?

In a tty Console, I disabled gdm.service and installed and enabled lightdm.service

With lightdm, lightdm comes up and I am able to enter my password, then the white screen Oops, something went wrong comes up.

Can anyone point me in the right direction?


What is the graphics on the Pi 4? Maybe edit the MODULES= in the mkinitcpio.conf and rebuild the kernel module first.

Edit: Maybe it’s the same issue where gdm loads too early before graphics module is loaded.

1 Like

To rule out the display manager thing, try starting an X session from the terminal. This will also give you any potential errors into either stderr or stdout.

1 Like

Are you running into the same issue if you install ArchARM? I would try that and figure out the differences between your script and the AARM install?


as user I entered startx, it failed due to missing xterm. Installed xterm, then startx gave twm. In twm I was able to start hardinfo (system profiler & benchmarks). Everything having to do with graphics was “unknown”.

For some reason the gpu is not being recognized. Right now I am in mate, and it gives the following for Graphics Processors:
Device Tree Node
Path /gpu
Compatible “brcm,bcm2711-vc5”
Status “okay”
Name “gpu”

I will exit Mate and boot Gnome and give results of hardinfo.


The hardinfo in Gnome is exactly as above from Mate. So it recognizes the gpu the same as Mate.

I assume you mean install the Arch way using the instructions on the main website page?

Well, it’s been a long day of testing and now troubleshooting. My brain is mush. It’s almost time for the 10 O’clock news, that’s it until tomorrow.

Thanks everyone.


Interesting. How are you booting into Gnome to confirm that it works, if Gnome isn’t booting?

To start gnome from startx, covers it well.

1 Like

I see some issues with gnome-shell updates here at the forum also currently (not ARM) what versions are currently used on aarm?

It is now 1:45 AM. I couldn’t sleep thinking about this. So I decided to get this down on paper so to speak.

There are 7 DEs and 3 WMs supported by EndeavourOS. In my testing, I used both an Odroid N2+ aarch64 (64 bit) computer and a Raspberry Pi 4 armv7h (32 bit) computer.

On the Odroid N2+, all 7 DEs and 3 WMs installed and worked well that’s 10 out of 10

On the RPi4, 5 DEs and 3 WMs installed and worked well. 2 DEs installed OK but failed to operate properly. Those two DEs were Gnome 40 and Budgie-desktop.

Gnome 40 and Budgie are essentially the same thing with different shells, Gnome uses gnome-shell and Budgie uses budgie-shell. I’m guessing fixing one will fix the other.

As for the installation procedure. The 7 DEs are all installed the same. The 3 WMs are handled silightly differently, so let’s throw out the WMs for consistency and concentrate on the 7 DEs.

All package lists were pulled from the endeavouros-team github site from the netinstall.yaml file. In the netinstall.yaml file, there is a section named “Base-devel + Common packages” This package list was used for all 14 installs to establish a base install. So all fourteen of those were indentical. Then the installer refers to the same netinstall.yaml file and uses the individual DE package lists. These were duplicates between say gnome Odroid N2 and gnome raspberry Pi 4 and so forth for the other 6 DEs.

The same packages were installed for all test installs EXCEPT for
Odroid N2 used @jonathon 's kernel 5.11.2-zen-1-ODROID kernel,
RPi 4 used kernel 5.10.31-ARCH

Odroid N2 used linux-firmware
RPi4 used linux-firmware AND raspberrypi-firmware
That’s all I can think of at the moment.

But even with these differences RPi4 still had 5 DEs that worked fine.

The symptom was the OS boots up until GDM or Lightdm attempts to start and the white page with “Oh, no. Something bad has happened. Yada Yada” appears. This is a sign that the graphical part of the OS is not working.

Next clue is courtesy of @codic12. Thank you BTW. Which was try starting an X session from the terminal. In a tty Console window did a startx. Failed because no xterm. installed xterm and ended up in twm with three tiled xterm windows. From the xterm windows I was able to manually type in commands to launch Firefox, gedit, and hardinfo (System Profiler & Benchmarks) and other apps. So this proves the underlying graphics system is in place and working.

Startx uses twm for the window manager and Gnome uses mutter for the window manager. twm works, mutter not so much.

Now back to the RPi4 5 DEs that worked. KDE and LXQT definately don’t use mutter. I don’t think xfce4 or Mate uses mutter. Cinnamon uses a version of mutter. Hardinfo lists the Cinnamon version’s name immediately followed by (mutter). Even if it is the same as mutter, knowing Cinnamon I doubt they are using the latest version mutter.

So the thing that the failing RPi4 DEs have in common is mutter.
The things that are different between the Odroid Gnome which works and the RPi4 Gnome which doesn’t work is different versions of the kernel and an additional firmware package for RPi4. I doubt it is the firmware package, so I’m looking at mutter.

So the question is:
Is there something in the 5.11.2-zen-ODROID kernel that the latest version of mutter needs that is not present in the older 5.10.31-ARCH kernel?

Now back to bed to think some more…errr sleep some more.


Folder /var/log contains some logs (at least Xorg.0.log), maybe they can give more details about the problem?

1 Like

xorg-server-1.20.11-1 seem problem … downgrade if can ! it will boot